


Creating a New Catalog
To catalog items in Portfolio you “add” them to an open catalog—Portfolio then handles the cataloging automatically.    You can 
add items to a new catalog or to an existing one. New catalogs created in Portfolio are initially empty. 
This section shows you how to create a new, empty catalog.

Note: You'll notice that the Portfolio catalogs you create are automatically given a “.fdb" filename extension, even on the 
Macintosh. This is to ensure cross-platform access to your catalogs. Macintosh users who do not work in a cross-platform 
environment can delete the “.fdb" extension in the Save dialog when the file is named and saved.

To create a new catalog:
1. Open the Portfolio application by double-clicking its icon. When the Welcome dialog appears, select “Create a New 

Portfolio catalog,” then click “OK.”

To prevent the Welcome dialog from being displayed each time you open a catalog, deselect this option in 
Edit>Preferences.

— or —

1. Click “Cancel” at the Welcome dialog. When Portfolio opens, select “New...” from the File menu, or click the “New 
Catalog” button    on the button bar, or press Command+N (Mac OS) or Ctrl+N (Windows).

2. Specify a name and location for the new catalog, then click “Save.”

Portfolio creates the catalog and opens a blank Gallery window.

3. Add items to the catalog.

Specifying a Default Catalog
You can specify a Default Catalog that will be opened automatically each time you start Portfolio.

To specify a Default catalog:

1. Open or create the catalog that you want to use as the Default.

2. Select “Set Default Catalog” from the File menu.

A checkmark appears beside the menu command indicating that a Default Catalog has been assigned. To deselect the 
catalog, select “Set Default Catalog” again, or specify another catalog as the default.

See Also:
Adding Items to the Catalog 



Adding Items to the Catalog
You can easily add items (including whole folders and volumes of items) to a catalog from within Portfolio, or by dragging and 
dropping them into an open Gallery window.
If you add items to a catalog from disks or network volumes, you can dismount the drives or volumes and continue to use the 
catalog—viewing, searching, and organizing cataloged items—without remounting the source file volumes. The only time you 
need to access the source file is when copying the item to another application, when printing from the original, or when using the 
source file functions available in Portfolio such as previewing, editing, copying, renaming, or deleting a source file. And even 
then, Portfolio automatically prompts you to insert the necessary volume.
When you add items to a catalog, Portfolio displays the Cataloging Options dialog so that you can select or change cataloging 
options before cataloging begins. 
Portfolio provides default Cataloging Options that will serve most needs, so you can quickly catalog items without spending time 
learning about these options. (To select the default options, click “OK” on the Cataloging Options dialog.) You can bypass this 
dialog altogether by disabling this option in Portfolio’s Edit >Preferences dialog. With “Show Cataloging Options” disabled, 
Portfolio automatically applies the default cataloging options (or the last-saved options if any were specified in Catalog 
>Cataloging Options) each time you add items to the catalog.
When the Cataloging Options have been set, Portfolio begins cataloging the items and displays a progress window so you can 
track its progress.

Note: Since Portfolio works with thumbnails and references to item source files rather than the actual file content, if you move 
or rename files and then wish to access the source file contents, (such as when copying items to a document in another 
application, Previewing the item, or editing the source file) you will need to “update” the catalog records. 

To Add items to an open catalog:
Note: You must have a catalog open, either a new, empty catalog or an existing catalog, before you can add items. 

1. Drag and drop selected files, folders, or volumes into the open Gallery window. 

— or    —

1. Choose “Add Items...” from the Catalog menu, then locate the files, folders, or volumes of items that you want to add to the
catalog.

2. From the Cataloging Options dialog, select either “Add” or “Add & Update” from the Modify Method option of the General 
tab. You can review or change the other options, or simply allow Portfolio to use the default options presented.

3. Click “OK.”

Portfolio scans the volume(s) containing the source files, examines each file before adding it to the catalog, extracts the 
data as specified in Cataloging Options, and displays the “Cataloging Status” dialog to keep you posted on its progress.

When cataloging is complete, the items just added to the catalog will be displayed in the Gallery window.

See Also:
Creating a New Catalog 
Updating Catalog Items 
Cataloging Options 



Updating Cataloged Items
When information associated with an item’s source file changes, you will want to “update” the catalog to reflect the changed 
information. You can update items individually, or update whole folders and volumes at the same time. You can even have 
Portfolio track changes and update automatically (see sidebar Tip).
The process of updating changes the pointers to each item’s source file (if these have changed). Updating can also be used to 
regenerate item thumbnails (such as when the source file has been edited); to read in any new or modified information such as 
file modification date; and to update any keywords, descriptions, custom field data, etc. that is embedded in the file. You can 
control which types of fields are updated using the options in the Cataloging Options dialog that is displayed when you update 
items. You can also set default cataloging options (Catalog >Cataloging Options).
You will want to update cataloged items when you:
• Move, rename, or delete files, folders, or volumes that have been cataloged. 
• Edit source file(s) and want the catalog records to reflect those changes.
• Want to change the thumbnail size displayed in the catalog.

Two Ways to Update
There are two ways to initiate an update: 

1. Using the “Add Items...” command (or by dragging and dropping files into an open catalog). Using this method you provide
Portfolio with the path to the source files (you tell Portfolio where to find them.) Portfolio will scan the files and update the 
information. For example: If you know which files, folders, or volumes contain source files that need to be updated and you 
have easy access to those files, or if you have a large number of items to update, you can drag and drop them into the 
catalog’s open Gallery window, or alternately select Catalog > Add Items, then locate the files or folders using the system 
folder hierarchy. 

2. Using the “Update Items...” command. When you update using this method you are asking Portfolio to locate the source 
files. Portfolio will attempt to locate the files using the pathname in the catalog. If the files are found, the records will be 
updated. If the files are not found, you will be asked to locate them. For example: If you don’t know which links have 
changed, or you have just a few items to update and you don’t have easy access to the source files (such as when they 
are spread across a number of folders or volumes), you would select those items in the Gallery window, then choose 
Catalog > Update Items to initiate the update. 

After you initiate the update, Portfolio displays the Cataloging Options dialog so that you can select or change options before 
updating begins. Portfolio provides default Cataloging Options that will serve most needs, so you can quickly update without 
spending time learning about these options. (To select the default options, click “OK” on the Cataloging Options dialog.) You can 
bypass this dialog altogether by disabling this option in Portfolio’s Edit >Preferences dialog. With “Show Cataloging Options” 
disabled, Portfolio automatically applies the default cataloging options (or the last-saved options if any were specified in Catalog 
>Cataloging Options) each time you add or update catalog items.

To Update using the Drag and Drop/Add Items method:

1. Open the catalog that you want to update. 

2. Locate the files, folders, or volumes to be updated, then drag and drop them into the open Gallery window. 

— or —

2. Choose “Add Items...” from the Catalog menu, or press Command+E (Mac OS) or Ctrl+E (Windows), then locate the files, 
folders, or volumes that you want to have updated.

The Cataloging Options dialog will be displayed, allowing you to choose a variety of options for updating the files. 

3. From the Cataloging Options dialog, select “Update,” “Add &Update,” or “Update Unconditionally” from the Modify Method
option of the General tab. 

4. You can review or change the other options, or simply allow Portfolio to use the default options presented. Click “OK.”

Portfolio scans the volume(s) containing the source files and updates item records based on the Cataloging Options 
settings.

To Update using the Update Items method:

1. Open the catalog that you want to update. 

2. In the Gallery window, select the items that you want updated. To update all the items, choose Edit >Select All 
[Command+A (Mac OS) Ctrl+A (Windows)].



3. Choose Catalog > Update Items... [Command+U (Mac OS) Ctrl+U (Windows)]. 

4. Review or change    Cataloging Options (to change Modification method see sidebar Tip), or simply allow Portfolio to use 
the options presented, then click “OK.”

Portfolio searches for each item’s source file using the pathname stored in the item record. 

If the source file is found, the record is updated based on the Cataloging Options settings. 

If the source file cannot be found, you are prompted to locate it. If you select a new file for the selected item, the record is 
updated with information from the new file, based on the Cataloging Options settings.

If the source file cannot be found and you click “Skip File” when prompted to locate the file, the selected record is left 
untouched.

Updating to Regenerate Thumbnails
You can elect to regenerate thumbnails when you update catalog items by choosing this option in the Cataloging Options dialog 
(Catalog >Cataloging Options: Rules tab). Regenerating during an update offers the same options: by extracting the thumbnail 
from the source file or by building a thumbnail. 
You may want to regenerate the thumbnail for an item when you have edited the file and the thumbnail has changed. In this 
case, choose Regenerate Thumbnails from the Rules tab, then choose “Update Items.” The Cataloging Options dialog opens 
with the default update method “Update” selected. Update checks the modification date; since this has changed, the item will be 
updated.
You might also want to regenerate thumbnails in order to switch between using a 112 x 112 pixel thumbnails and the larger 256 x
256 pixel thumbnails. In this case, choose Regenerate Thumbnails from the Rules tab, then select “Update Items.” This will 
open the Cataloging Options dialog where you can switch the update type to Update Unconditionally; Update Unconditionally 
does not check to see if modification date has changed. A standard Update would check for a modification date change and skip 
the update because the source file has not been modified.

Note: When you change Modify Method setting during an update, it only changes the modification method for that session. 
That is, if “Add” was set as the Modify Method previously, it will still be set to “Add” after the “Update Items” command is 
executed.

See Also:
Cataloging Options 



Identifying Missing Files
Portfolio’s Missing Files command locates cataloged items whose source file has been moved, renamed, or deleted, and the 
catalog link has not been updated to reflect this change. 

Note: Portfolio searches for missing files on mounted volumes only. If a volume containing cataloged item source files is not 
mounted, Portfolio will not report on those files.

To check for Missing Files:

1. Choose “Missing Files...” from the Catalog menu (or press Command+Option+M (Mac OS) or Ctrl+Shift+M (Windows).

Portfolio compares each item’s pathname as stored in the catalog record against all mounted volumes to see if the source 
file can be found at that location. The results are reported in the Missing Files dialog.

2. If Missing Files were located, select each item, then click either the Update or the Delete button at the bottom of the dialog 
to update the catalog.

Update: Initiates a catalog Update. Allows you to manually locate the missing source file.

Delete: Deletes the item from the catalog. Allows you remove items from the catalog if the source file cannot be located.

See Also:
Updating Cataloged Items 
Deleting Items from a Catalog 



Cataloging Options
Unless you indicate otherwise in Edit >Preferences, Portfolio displays the “Cataloging Options” dialog box whenever you drag 
and drop files or folders into an open catalog. Whether or not the Cataloging Options dialog is displayed, the current Cataloging 
Options settings are checked any    time that you add items to a catalog or update the items in a catalog.

See Also:
Modification Method 
Thumbnails: Extracted vs. Generated 
Thumbnail Size 
Mappings 
Excluding Files from being Cataloged 



Modification Method
When you add items to the catalog, or update existing items, you can select from the following options:
• Add
• Add Unconditionally
• Add & Update
• Update
• Update Unconditionally
Which method you select will depend on what you are trying to accomplish. If you are only adding items, choose “Add” or “Add 
Unconditionally.” If you are only updating items, choose “Update” or “Update Unconditionally.” If you know that you are both 
adding and updating, or if you want Portfolio to intelligently add or update as necessary, select “Add &Update.” “Add &Update” 
provides the most flexibility, and is a good choice if you want to automate the process as much as possible (in this case you 
might also want to prevent the Cataloging Options dialog from being displayed each time items are added or updated—you can 
disable this option in Edit >Preferences).
Add: Adds item files to the catalog as new records if Portfolio determines that the files do not already exist in the catalog. If a 
matching record already exists, the file is skipped.
Add Unconditionally: Adds files to the catalog as new records, regardless of whether a record for the file already exists in the 
catalog. 
Add &Update: Performs both the Add process and the Update process. Portfolio adds a new record to the catalog if it determines
that the file does not exist in the catalog. If a matching record is found, Portfolio updates the record.
Update: Updates existing records in the catalog if Portfolio determines that the files match existing records. If no matching record
is found in the catalog, the file is skipped.
Update Unconditionally: Updates existing records in the catalog looking only at the filename and ignoring record criteria used in 
the normal Update logic. Specifically, Portfolio does not examine file dates and paths when determining whether the file matches 
an existing record.

See Also:
Adding Items to the Catalog 
Updating Cataloged Items 
More About Update Unconditionally 



More About Update Unconditionally
Update Unconditionally determines a source file match based only on filename only, not pathname. This can be useful when 
updating the catalog record from a copy of the source file. 
Update Unconditionally is also useful when you want to update the catalog record but the file has not changed, such as to 
change catalog thumbnail size. (In this case, if you select Update rather than Update Unconditionally nothing will happen, since 
the file has not changed).

Note: Exercise caution when using Update Unconditionally. This is a powerful and useful tool, but it has the potential to effect 
unwanted changes: When you catalog two files by the same name located in different directories, Portfolio differentiates 
between the two records using their different pathnames. When you Update Unconditionally, Portfolio discards the pathname 
in its record search and updates the first record with the selected filename that it comes to. For example, assume that C:\
Artwork\Box.jpg and C:\Photos\Box.jpg are both cataloged in the same catalog. You select Update Unconditionally in order to 
enlarge the catalog thumbnail for C:\Photos\Box.jpg. Portfolio searches the catalog records for “Box.jpg” and finds the record 
for C:\Artwork\Box.jpg, which it updates. This replaces the thumbnail in the record for C:\Artwork\Box.jpg with the thumbnail for
C:\Photos\Box.jpg.



Thumbnails:    Extracted vs. Generated
An Extracted Thumbnail is one that already exists in the source file. If “Extract Thumbnail” is enabled (Catalog >Cataloging 
Options >Rules tab), Portfolio will look for and extract Thumbnails from various file types, such as:
• Photoshop files
• EPS files
• Adobe Illustrator files
• Any Macintosh file with a thumbnail in the "pnot" resource
If the source file does not contain a thumbnail, Portfolio will attempt to generate one.
A Generated Thumbnail is one that is created by Portfolio by reading the source file with an appropriate translator. If “Extract 
Thumbnail” is disabled, Portfolio will always attempt to generate a thumbnail, even if a thumbnail exists in the source file. 
Depending on the type of embedded thumbnail, Portfolio may be able to render a better thumbnail than that supplied in the 
source file. 

Note: Extracting thumbnails is faster than generating them.

See Also:
Thumbnail Size 



Thumbnail Size
Portfolio allows you to store thumbnails at either of two different sizes: 112 x 112 pixels, or 256 x 256 pixels. 
The advantage in having the larger size thumbnails is as you might expect—improved resolution when viewed at the larger size. 
The disadvantage is that the larger thumbnails occupy about four times as much catalog space (typically 20K vs 5K). 
Thumbnails that are embedded in the source file typically range in size from 80 x 80 pixels to 128 x 128 pixels. Portfolio will scale
these extracted thumbnails to the closest size, typically 112 x 112 pixels. So if you elect to save thumbnails at 256 x 256, you will
probably want to also disable extracting thumbnails and allow Portfolio to generate the larger thumbnails.



Mappings
Portfolio Mappings give you the ability to extract text data that is embedded in source files fields other than the standard 
Description and Keywords fields. 
Typically, software that allows you to add information to a file (Photoshop’s File Info is a good example) assigns a numeric ID, or 
Tag, to each field of embedded data. Using Portfolio’s Mappings feature you can map this field ID to a Custom Field in your 
catalog, and have Portfolio read the source file data into the Custom Field.
Portfolio provides currently known Tag Codes for popular formats (Photoshop, IPTC, TIFF). These are displayed in the Mappings
tab (Catalog >Mappings). But you are not limited to the pre-installed codes—you can add Tag codes from any software that 
supports this convention, and also add new codes as they become available. 
To use Mapping, you must create a Custom Field (Catalog >Administration >Custom Fields tab) for each tagged field that you 
want to extract from item source files. If the ID Code for the source file Tag is already listed in the Mappings table, all you need to
do is Edit the entry and add the Custom Field name that you want to map it to. If the necessary code is not listed in the table, you
can Add it to the list and then map it to your Custom Field. 

To Enable or Disable an existing Mapping:
Note: Mappings must be created before they can be used. 

1. From the Mappings list (Catalog > Cataloging Options: Mappings), select the Mapping that you want to enable.

2. Click the “Edit” button or double-click the selection to open the Edit dialog or (Macintosh only) click in the first column of 
the Mapping that you want to change. 

3. From the Edit dialog, select “On” from the “State” pop-up menu, then click “OK.”

A check indicates that the Mapping is enabled: Portfolio will extract data from the source file field and place it in the 
indicated catalog Custom Field. No check indicates that the Mapping will be ignored.

4. Click “OK” to close the Cataloging Options dialog and save the settings.

Notes about Mappings:

1. Mappings (that are enabled) are used during both Add and Update operations.

2. You cannot map to keywords or descriptions.

3. Some tags are automatically mapped to Keywords or Description. These tag codes cannot also be used to map to a 
Custom Field.

You cannot map one tag code to multiple Custom Fields.

To Map an existing Tag Code to a Custom Field:

1. Create a Custom Field (Catalog >Administration > Custom Fields) for each source file tagged field that you want to extract.

2. Select Catalog > Cataloging Options... [Command+J (Mac OS) or Ctrl+J (Windows). Click the Mappings tab to select it.

3.  Select the first source file Tag Title/Code that you want to map, the click “Edit.”

The “Mapping” dialog will be displayed, showing the selected Tag and its ID Code.

4. Assign a catalog Custom Field to the Tag by selecting it from the Field pop-up menu.

5. Set the State to On or Off. 

On instructs Portfolio to import the data from the Tag. Off instructs Portfolio to ignore the Tag.

6. Select the appropriate Action from the Action pop-up. 

Replace replaces any existing data in the specified Custom Field with the data from the source file field. Append adds data
from the source file field to any existing data in the catalog Custom Field. If the field is a Multi-valued field, Append adds a 
new value to the list.

7. Click “OK” to accept the settings and return to the Mappings tab.

8. Repeat steps 3 through 6 for all the tagged fields that you wish to import.

To Add a Tag ID Code to the Mappings list:

1. Create a Custom Field (Catalog >Administration > Custom Fields) for each source file tagged field that you want to map.



2. Select Catalog > Cataloging Options... [Command+J (Mac OS) or Ctrl+J (Windows). 

3. Click the Mappings tab to select it, then click “Add.”

4. Enter the Tag ID Code, and enter a Title for the Tag.

Data is extracted using the ID Code. The tag Title is informational—you can name the tag anything you like.

5. Assign a catalog Custom Field to the Tag by selecting it from the Field pop-up menu.

6. Set the State to On or Off, and select the appropriate Action from the Action pop-up. 

7. Click “OK” to accept the settings and return to the Mappings tab.

8. Repeat steps 3 through 7 for all the tagged fields that you want to map.



Excluding Files from being Cataloged
Using Portfolio Cataloging Options, you can tell Portfolio to skip files of a certain File Type or Name.
Exclude by Type: You can exclude files of a specific File Type from a catalog by deselecting or deleting that file type from the File
Types list of the Cataloging Options File Types tab (below).
Exclude by Name: You can exclude files with a specific File Name by creating an “exclusions” list that specifies an explicit set of 
file names or patterns. File name exclusions are specified in the Cataloging Options Exclude tab.

File Types
Portfolio recognizes and catalogs all file types, regardless of whether the file type appears on the File Types list or not. You only 
need to add file types to the list if you want to exclude a type that does not appear on the list, or if you will be excluding some 
types and including other types that do not appear on the list. 

To add a File Type:

1. Choose Catalog >Cataloging Options [or press Command+J (Mac OS) or Ctrl+J (Windows)].

2. Click the File Types tab to select it.

3. Click “Add.”

4. Enter the file type information, or click “Same As...” and locate a file of the same type. Portfolio will copy the parameters of 
this file type into the fields.

5. Click “OK” to add this file type to the list.

Exclude
Using the Cataloging Options Exclude tab you can exclude files with a specific File Name by creating an “exclusions” list that 
specifies an explicit set of file names or patterns. 

To add a File Name    to the exclusions list:

1. Choose Catalog >Cataloging Options [or press Command+J (Mac OS) or Ctrl+J (Windows)].

2. Click the Exclude tab to select it.

3. Select the file name search parameter from the pop-up menu: Begins with, Contains, or Ends with. 

4. Enter the filename or partial name that you want to exclude from cataloging. Letter case (uppercase/lowercase) is ignored.

5. Click “Add.” 

Portfolio searches each pathname and each segment of the path for text strings matching any of the parameters you enter.
For example: If you enter “Begins with: DUP” and “Ends with: 97” Portfolio will exclude “Duplicate_PH050,” “Report_97,” 
and “C:\Duplicates\Image.jpg”



Keywords
Each item in a catalog has certain information associated with it, such as filename, file type, volume, and so on. Each item can 
also have one or more keywords associated with it. A keyword is a word or phrase that you associate with a particular item, and 
a good keyword list can be a valuable tool for finding the material you need in a catalog. 
Keywords can be extracted from the item’s source file and/or added to item records manually. An unlimited number of keywords 
can be assigned to each item. In a network environment, using catalog access level permissions a catalog Administrator can 
control who is allowed to edit item keywords. 
A catalog can also include a preset list of keywords called the Master Keywords List. Master Keywords can only be created with 
Administrator access. Users select keywords from the Master Keyword list, which helps maintain consistent keywording among 
items in a catalog or across multiple catalogs. 

See Also:
Viewing Item Keywords 
Adding, Assigning, and Deleting Keywords 
Adding Keywords by Extracting them from Source Files 
Creating a Master Keywords List 



Adding Keywords by Extracting Them from Source Files

If you have selected the “Extract Keywords” option (Catalog >Cataloging Options: Rules) for Adding and/or Updating, Portfolio 
examines all source files for keywords created in their native applications when you add and/or update items in a catalog. As 
items are cataloged or updated, extracted keywords are added to the item’s keyword list according to the settings in the Rules 
tab.



Viewing Item Keywords
You can view the keywords associated with a selected item in the following locations: 
• In the Gallery window List view (View >List)
• In the Gallery window Record view (View >Record), if keywords have been included in the view (View>Customize). 
• In the Keywords tab of the Item Properties dialog (Item>Item Properties:Keywords)
• In the Edit Keywords dialog (Item >Edit Keywords)
When keywords are shown, the number beside each keyword indicates how many items in the catalog have that keyword 
assigned. 

To display the keywords for an item:

1. Select the item, then choose Item Properties... from the Item menu, or press Command+I (Mac OS) or Alt+Enter 
(Windows). 

2. In the Item Properties dialog, click the Keywords tab.

The item's keywords appear in a list box on the left. Master Keywords appear on the right.

3. Click “OK” when you are finished viewing the keywords.

To display the keywords for an entire catalog:

1. Choose Catalog Properties... from the Catalog menu,      or press Command+Option+J (Macintosh) or Ctrl+Shift+J 
(Windows). 

The “Catalog Properties” dialog is displayed.

2. Click the Statistics tab to select it.

3. Click “Calculate...”

The keywords for all items in the catalog, and the number of occurrences of each keyword, are displayed in the list box on 
the left. The more items in the catalog, the longer this process will take.



Adding, Assigning, and Deleting Keywords
You can manually enter and assign keywords to the items in the catalog, and you can edit an item’s keyword list whether 
keywords were added manually or extracted from the item’s source file. With the exception of the Master Keywords List, you 
cannot add keywords to the catalog without assigning them to at least one item.
To add and assign keywords to items you must first select the items in the Gallery window. Once the items are selected you can 
assign keywords in the following ways: 
• Single items: From the Item Properties dialog (Item >Item Properties), from the Edit Keywords dialog (Item >Edit Keywords), 
or from the Master Keywords Palette (View >Master Keywords Palette). 
• Multiple items: From the Edit Keywords dialog, or from the Master Keywords Palette. 

 To Add keywords to a single    item:

1. Select the item that you want to add keywords to, then choose Item Properties... from the Item menu (or press Command+I
(Mac OS) or Alt+Enter (Windows).

The “Item Properties" dialog is displayed.

2. Click the Keywords tab to select it.

3. Type a keyword in the text box, then click “Add.”
Note: If the catalog administrator has restricted keyword additions to only those in the Master Keyword list, Portfolio checks 
your additions against the list and notifies you of any “illegal" keywords. 

— or —

3. If you have a Master Keywords list, select a keyword from the Master Keywords list, then click “Assign,” or double-click the
Master Keyword.

4. When you are finished adding keywords, click “OK” to close the dialog and assign the keywords to the item.

To Remove a keyword from an item:

1. Select the item that you want to add keywords to, then choose Item >Item Properties [or press Command+I Mac OS or 
Alt+Enter (Windows).

The “Item Properties" dialog is displayed.

2. Click the Keywords tab to select it.

3. From the item’s keyword list, select the keyword that you want to remove.

4. Click “Remove.”

5. When you have finished selecting all the keywords that you want to remove from the selected item, click “OK.” This closes 
the dialog and removes the keyword(s). 

The keywords are not actually removed from the item until you click “OK.” If you accidentally remove the wrong keywords, 
you can click “Cancel” to close the dialog without applying the changes.

When you delete a keyword it appears in the text entry box. This is handy if you decide you want to add it back—you can 
do so easily by clicking the “Add” button.

To Add a keyword and assign it to multiple items:

1. In the Gallery window, select the items that you want to add keywords to

2. Choose Item > Edit Keywords... [or press Command+Y (Macintosh) or Ctrl+Y (Windows)].

The Edit Keywords dialog opens.

All the keywords assigned to at least one of the selected items will be displayed in the keywords list.

3. Type a keyword in the text box, then click “Add.”

The “State” of the keyword is changed to “Add,” indicating that it will be added to the catalog and assigned to the selected 
items.

Note: You do not need to click “Assign” after you add a keyword—“Add” implies “Assign” (that is, all keywords with either 
Add or Assign in the State field will be assigned to all selected items in the active Gallery when the dialog is closed. “Add” just
tells you it’s a new keyword).



4. When you have finished adding keywords, click “OK” to close the dialog and assign the keyword to the selected items.

If you close the dialog by clicking “Cancel,” all changes are discarded.

To take a keyword that is already assigned to one item and assign it to other items:

1. In the Gallery window, select both the item that has the keyword you want to assign, and the items that you want to assign 
the keyword to.

2. Choose Item > Edit Keywords... [or press Command+Y (Mac OS) or Ctrl+Y (Windows)].

The Edit Keywords dialog opens.

All the keywords assigned to the selected items will be displayed in the keywords list.

3. Locate the keyword that you want to assign to the selected items.

4. Click “Assign.”

The “state” of the keyword is changed to “Assign.” 

5. When you have finished assigning keywords, click “OK” to close the dialog and assign the keyword(s) to the selected 
items.

To assign keywords to items using the Master Keyword list:

1. In the Gallery window, select the items that you want to assign Master Keywords to.

2. Choose Master Keywords Palette from the View menu, (or press Command+K    (Macintosh) or Ctrl+K (Windows).

The Master Keywords Palette will be displayed, showing all the Master Keywords in the catalog.

3. On the Master Keywords List, locate and select the keyword(s) that you want to assign to all the selected items. [Press 
Command-click (Mac OS) or Ctrl-click (Windows) to select keywords non-contiguously.]

4. Click “Assign.”

The keywords are assigned to all the selected items immediately.

To find all items to which a keyword is assigned:

1. Open the Master Keywords Palette [View > Master Keywords Palette, or press Command+K (Mac OS) or Ctrl+K 
(Windows)].

2. Select the keyword that you want to change, then click “Find,” or double-click the word.

3. In the Gallery window, all the items with that keyword will be displayed. 



Item Descriptions
In addition to adding keywords to any item, you can add a description up to 32,000 characters long. You can use the description 
field to keep track of any information about the source file that you might find useful or important, but information that you 
probably won’t use to locate catalog items. You might want to use the Description field for photo captions, small amounts of 
marketing copy, or miscellaneous notes.
If the original application provides a way for you to enter and save descriptive text with the source file, Portfolio can often extract 
this information automatically as it catalogs the item. Otherwise, you can add or edit a description after cataloging. In a network 
environment, a catalog administrator can control who edits descriptions.

Adding Descriptions by Extracting Them from Source Files
If you have selected the “Extract Descriptions” option (Catalog >Cataloging Options: Rules) for Adding and/or Updating, Portfolio
examines all source files for    descriptions created in their native applications when you add and/or update items in a catalog. As 
items are cataloged or updated, extracted descriptions are added to the catalog according to the settings in the Rules tab.

Entering and Editing Item Descriptions
You can manually enter item descriptions into a catalog, and you can edit existing descriptions whether they were added 
manually or extracted from an item’s source file. 

To enter or edit a description manually:

1. Select the item to which you want to add a description, then choose “Item Properties...” from the Item menu.

The “Item Properties” dialog box appears with the General tab selected.

2. Type a description in the Description text box, then click “OK.”

The description is added to the item.
Note: If the Description text box is disabled, it indicates that you do not have permission to edit descriptions for items in the 
open catalog (requires Editor mode or higher). If you are working in a network environment, check with your catalog 
administrator.



Adding Data to Custom Fields
If custom fields have been defined for a catalog, you can change their value (or contents). For example, you can add 
photographers' names to a custom “Photographer” field in a catalog of photographic images. Some custom fields even allow 
more than one entry, and others allow you to select from a predefined list of items so that consistency is maintained from record 
to record, and/or between catalogs. 

Note: You must have Editor level access or above to a catalog in order to change its Custom Field values. Creating new 
Custom Fields requires Administrator level access. 

To Edit existing Custom Fields:

1. Select an item in a Gallery window, then choose Item >Item Properties.

2. In the Item Properties dialog, click the “Fields” tab to select it.

All custom fields for the catalog are displayed, even if no data is currently entered in a field for the selected item.

3. Select the field you want to change, then click “Edit...” 

The “Edit” dialog box for the field will be displayed. This dialog differs for the different field types.

4. Type the appropriate value in the text box, then click “OK” to close the edit dialog.

If you enter a value that is incorrect for the field type, clicking “OK” produces no result. (Re-enter the proper value type or 
click “Cancel.”)

5. Click “OK” to close the dialog and accept the changes.

See Also:
Adding Custom Fields 



Replacing Keywords, Descriptions, and Field Values using Search Parameters
You can easily replace keywords, descriptions, and Custom Field values for multiple items in a catalog at the same time using 
Portfolio’s powerful Replace function. For example, if you have defined a Custom Field for the print date for your images and the 
print date for some of those images slips by a week, you can replace the incorrect date in that field for all the affected images at 
once. You can even search on a different field than the field being replaced, and you can choose to search all the items in the 
active Gallery, or limit the search to only the selected items. 

To Replace items based on field values:

1. Choose Replace... from the Catalog menu (or press Command+Option+R (Mac OS) or Ctrl+Shift+R (Windows).

The “Find and Replace” dialog box appears.

2. Select the Context of the search using the Context radio buttons.

• Replace all Items in Gallery: Disables the Find and forces the Replace value into all records in the Gallery.

• Search Selected Items:For the selected items, Replace the value for all records matching the search criteria.

• Search Gallery: For all items in the Gallery, Replace the value for all records matching the search criteria.

Unselected records are not affected.

3. Enter the parameters of the Find by selecting the field to be searched and a search clause from the pop-ups, then enter 
the text string to search on.

Note: This step does not apply if you selected “Replace all Items in Gallery” in step 2. 

4. Enter the parameters of the Replace by selecting a field to be replaced from the Replace Field pop-up, then enter the data 
string that will replace the existing data in the selected field.

If the field you selected is a Multi-valued field, indicate whether you want the Replace value added to the list of existing 
values, or to replace the value indicated in the Find value field. 

Note: Exercise caution when you perform a Replace where the Find field is different than the Replace field and “Add to Multi-
valued List” is unchecked, as the entire contents of the Replace field will be replaced. 

5. Click “Replace.”

Item records matching the Find criteria will be located, and data in the indicated Replace field will be replaced. 
Note: Because the “Replace” command in Portfolio is replacing field data in item records that are already being displayed, 
and is not (like the Portfolio “Find” command) searching for items to display, the “Replace” command has no effect on the 
Gallery (other than to show any field data that was replaced during the Replace operation).

The Multi-value Fields option is only available when a multi-valued field is selected in the Replace clause. 



Preparing Documents and Images for Cataloging
Portfolio works directly with many products to make cataloging fast and easy. This section describes how to prepare documents   
in various applications so that cataloging them is as easy as possible.

Adobe Photoshop 3.0.x and 4.0.x, and 5.0.x
You can save thumbnails, keywords and captions from your Photoshop documents for use in Portfolio catalogs.

To include a thumbnail and preview in Photoshop:

1. Choose “General...” from the Preferences submenu in Photoshop’s File menu.

2. Click “More.”

3. In the Image Previews section of the dialog box, select “Always Save.”

4. Click “OK.”

To include keywords and captions in Photoshop:

1. Choose “File Info” from Photoshop’s File menu.

2. Enter your caption in the caption field.

3. Click “Next” to switch to the “Keywords” panel.

4. Enter your keywords.

5. Click “OK” to close the dialog box.

Adobe Illustrator 7.0 and 8.0
Illustrator automatically saves a thumbnail that Portfolio can display into native (.ai)files. 
For Illustrator EPS files, in the Save Options dialog, choose to save both a thumbnail and a preview.

Adobe PageMaker 6.5 (Macintosh only)
PageMaker saves thumbnails that Portfolio can display in the catalog.

QuarkXPress 3.31 and above    (Macintosh only)
You can save thumbnails of your documents for use in Portfolio catalogs.

To attach a thumbnail in QuarkXPress: 

• When saving a QuarkXPress document, make sure that “Include Preview” is selected in the QuarkXPress Save dialog 
box.

This will save a black-and-white thumbnail of the first page of your Quark document.



Scripting
A number of Portfolio commands can be accessed through Scripting.
Macintosh: Portfolio supports AppleScript and any other OSA-compliant scripting language. 
Windows: Portfolio supports OLE Automation, which can be accessed by a number of scripting languages such as Visual Basic, 
Visual C++, Java, etc.
For information and examples on the scripting interface for each platform, refer to the “Scripts” folder on the Extensis CD.

Note: Extensis Technical Support cannot provide instruction on how to use the various scripting languages.

The Scripts Menu
The scripts or applications that you write to automate Portfolio can be conveniently launched from within the catalog using a 
special Scripts menu. This menu is installed in the Portfolio menu bar when valid scripts are placed in a folder named “Scripts” 
located in the same folder as the Portfolio application. Scripts and applications located in the Scripts folder are added to the 
Scripts menu and are available as regular menu commands.

This feature is particularly useful for creating custom commands for catalog users. For example: A script could be written that 
takes the currently selected items and adds the current date to a custom “Publish Date” field in each record. By placing this 
script in the Scripts folder located in the Portfolio application folder, the user can execute the script by selecting it from the 
Scripts menu, without needing to know anything about scripts. In fact, the menu item would appear to be a built-in function of 
Portfolio.



Opening Catalogs
You can open a Portfolio catalog in a number of ways, and you can have multiple catalogs open at the same time.

To open a Portfolio catalog:

• Drag and drop a catalog icon onto the Portfolio application icon.

— or —

• Double-click a catalog icon.

— or —

• Double-click the Portfolio icon. When prompted to open a new or existing catalog, click “Open an existing Portfolio 
catalog,” then locate the catalog. 

To open Portfolio without a catalog, click “Cancel.”

— or —

• With Portfolio already open, click the Open Catalog icon    on the Toolbar, or choose “Open…” from the File menu, or press
Command+O (Mac OS) or Ctrl+O (Windows).

The catalog opens to the Gallery window. From the Toolbar you can access most of the major functions and options in Portfolio. 
You can change views, open new Catalogs, open additional Gallery windows, search the catalog, and more.

Note: If you open a protected catalog, you must enter the appropriate access password to view and modify catalog items. If 
the catalog won’t open, another user may have it open in Administrator mode or with the Portfolio browser. 

See Also:
Connecting to a server 
Catalog Access Levels 



Connecting to a Server
If the catalog you want to open is on a Portfolio Server, you will need to connect to the Server and then select the appropriate 
catalog. When accessing a served catalog, the Portfolio 4.0 application software is referred to as the “client.”

Note: The Portfolio Server is special software that allows you to share catalogs with more simultaneous users than is possible 
using standard system networking. If you need to access a catalog that has been shared using conventional networking, 
simply access the catalog the same way you access other network files. See your System Administrator for help.

To Open a catalog on a Portfolio Server:

1. Double-click the Portfolio icon and click “Open existing catalog.”

1a. Click the “Connect to Server” button (Mac OS) or the “Servers...” button (Windows). 

The “Connect to Servers” dialog will be displayed.

— or —

1. With Portfolio open, choose “Connect to Server...” from the File menu, or click the “Servers”    button on the Toolbar, or 
press Command+Option+O (Mac OS) or Ctrl+Shift+O (Windows).

The “Connect to Servers” dialog will be displayed.

2. Click “Add Server...”

The “Add Server” dialog will be displayed.

3. Enter the Name or IPaddress of the server you want to connect to.

Portfolio will connect to the Server and display a list of catalogs available on the Server.

4. Select the desired catalog from the list, then click “Open Catalog,” or double-click the selected catalog to open it.

Notes on accessing Served Catalogs from Portfolio (client):
• Windows clients must have TCP services active to access the Server. For Macintosh clients, the machine must be using Open 

Transport TCP; classic networking is not supported when accessing catalogs on the Portfolio Server.
• Clients cannot access a served catalog in Administrator mode.      To gain Administrator access to a catalog the catalog must be 

closed from the Portfolio Server application and opened in the Portfolio 4.0 application (either on the server machine or via 
filesharing).

• The client application will attempt to open the catalog in the mode set in the user's Preferences. If the preference is set to 
Administrator, the client application will automatically attempt to connect to the catalog in Publisher mode.
Note: The user will be asked to enter a password if the catalog requires it.

• For more information on installing and using the client, refer to the other sections of this Portfolio User Guide.



Viewing Catalog Items in the Gallery
When items are cataloged in Portfolio, a record is created for each one, and information about the item is stored in this record.    
Item information can include keywords, descriptions, and custom fields that you create, as well as the item thumbnail, source file 
name, creator, creation date, source file location, and other information gathered automatically when the item is cataloged.      A 
Catalog is therefore a collection of records that provides information about the items contained in it. 
When you view catalog items in Portfolio you are actually viewing the information contained in each item’s record, such as the 
item thumbnail, description, and keywords. Your window to these records is called the Gallery. The Gallery is the main window in 
Portfolio, and a Gallery window is opened automatically each time you open a catalog. There are three different Gallery views, 
allowing you to display and view catalog records in a variety of ways. 
A Toolbar at the top of the Gallery window gives you quick and easy access to some of the more commonly used functions and 
options in Portfolio. 
You can specify which catalog items you want to view in the Gallery by using the Find    function. You can view all the catalog 
items at once, or locate items matching specified criteria. 
You can easily switch between Gallery views using buttons on the Toolbar. The three Gallery views are: Thumbnail view , List 
view , and Record view . 
Each view can be customized    to show as much or as little information as you require. You can even customize the way that 
thumbnails are displayed—changing the display size, adding background colors, and even thumbnail borders. 
You can create multiple Galleries    to display as many or as few cataloged items as you wish, drag and drop items between 
Galleries, and save Galleries by name for viewing at any time. This allows you to have a large number of items in a catalog, yet 
be able to limit the view to a small number of specific items. 

See Also:
The Toolbar 
Searching the Catalog Using Find Options 
Customizing Gallery Views 



Contextual Menus
Portfolio displays menu commands on contextual menus for three separate features: Items (individual records), Gallery windows,
and item Previews. A contextual menu is a menu that pops up when you press a key while clicking the mouse (Mac OS, if the 
Contextual Menus Extension is enabled) or Right-click the mouse (Windows), in the appropriate area of a window. 
Item contextual menu: To access the contextual menu for an item, select the item, then Control-click (Mac OS) or Right-click 
(Windows).
Gallery contextual menu: To access the contextual menu for a Gallery, Control-click (Mac OS) or Right-click (Windows) anywhere
in the unused area of a Gallery window (Mac OS: You can even click in the scroll bars and Toolbar)—but be sure that you do not 
accidentally select a cataloged item or a button when you click.

Preview contextual menu: To access the contextual menu for an itemwhen the Preview window is active, Control-click (Mac OS) 
or Right-click (Windows) anywhere in the Preview window.



The Toolbar
The Toolbar at the top of the Gallery window (Mac OS) or Portfolio application window (Windows) allows you to easily access 
many of Portfolio’s commonly used features, including QuickFind, a fast way to find items in the catalog without opening the Find
window. As you place the mouse over each button, the button Tool Tip is displayed, indicating the button’s function.
Windows only:The Toolbar is a tear-off menu, and the last ten QuickFinds are listed on the QuickFind drop-down menu.



Searching the Catalog Using Find Options
You can search for catalog items by examining the items in any of the Gallery views, or you can speed your search using 
Portfolio’s Find function. You can search any field, including Custom and keywords. 
You will probably find that you will use different search strategies at different times. For example:

• If your catalog is small or you’re looking for ideas, you might start by looking through everything the catalog contains.
• If your catalog is very large or you have a general idea of what you’re looking for, you might want to look only at items related to

a particular subject or concept, or of a particular file type.
• If you’re in the final stages of a job, you probably know exactly what items you need.

Portfolio can display the results of the search in the current Gallery window (completely replacing the previous contents, if any), 
or in a new Gallery window. 

To open the Find window:

• Click the Find button on the toolbar.

— or —

• Choose “Find” from the Catalog menu.

— or —

• Press Command+F (Mac OS) or Ctrl+F (Windows).

To display the entire contents of a catalog:

• Choose “Find All” from the Catalog menu.

— or —

• Open the Find window and click the “Find All” button.

— or —

• Press Command+' (Mac OS) or Ctrl+' (Windows).

To find specific items in a catalog:

1. Open the Find window.

Portfolio opens the Find window and displays the default saved Find.

2. Use the Find window to describe what you are looking for, then click “Find.”

Portfolio lets you search for various attributes of an item, including filename, keyword, file size and so on. 

Found items are displayed in the Gallery window, replacing the items there. You can elect to have the found items 
displayed in a new Gallery window by clicking “Display results in new gallery” option before you initiate the Find.

Using QuickFind
You can quickly locate catalog items by keyword using the QuickFind field on the Toolbar.

To find items in a catalog using QuickFind:

1. Type in the keyword that you want to search for in the QuickFind text box located on the Toolbar at the top of the window.

Windows:You can select previously searched for items    by selecting the word or phrase from the QuickFind    combo box.

2. Press Return or Enter.

This initiates the search. Find searches both fields (Title and URL) of a URL Custom Field.

QuickFind uses the “starts with” search criteria and searches only keywords; the results are displayed in the current 
Gallery unless you indicate otherwise in Edit >Preferences. 



Streamlining Searches
Portfolio has several options that can help you search through a catalog quickly and effectively. For example, you can:

• Select the most efficient searches for Portfolio to carry out.
• Name and save frequently used searches (to save yourself from    having to re-enter the criteria each time).
• Customize the default search displayed when you open the Find dialog.

Indexed Fields
Indexed fields are fields that are included in a special Portfolio look-up table, to speed searching. While indexing speeds 
searching, it adds to the overall size of a catalog, so not all fields are indexed. 
Indexed fields appear in bold in the search criteria pop-up menu. Custom fields can    be indexed, if you select this option when 
the field is created. When you search on indexed fields, choose “matches” or “starts with” from the modifier pop-up menu for the
fastest searches.
Other types of searches may be somewhat slower because Portfolio must examine every entry in the catalog:

• Searching is slower when there is a large number of items that match your search criteria.
• Searching using “contains” or “ends with” is slower when the catalog is large.

• You can only search on single-value indexed fields. 
You can also sort the Gallery window on any indexed field (such as Catalog order, File Name, File Type, Creation date, Custom 
Fields that are indexed, etc.) 

Date/Time Fields
Times are always assumed when searching fields of the type “Date/Time,” even if a time is not entered, and when the “Display 
Time” option for the field is disabled. That is, if a time value was entered into the field (either by extraction from the source file 
when the item was cataloged or by entering a time in the field) and then hidden by turning off “Display Time,” the time will still be
noted by Portfolio when a search is requested. For example: Searching for “5/20/98” will not find a record which contains 
“5/20/98 3:00 pm” because the request is interpreted as “5/20/98 12:00:00.” This is true even if the time is not being displayed.

See Also:
Adding Custom Fields 
Sorting and Reordering Gallery Items 



Saving Finds
If you routinely need to locate particular types of items in a catalog, you can name and save a Find that will retrieve those items.
Your saved finds appear in the Saved Finds pop-up menu in the Find window. Whenever you want to use a Saved Find, choose 
its name from the menu or click the icon button on the Toolbar.

To Save a Find:

1. Set up your search in the Find window.

2. Choose “Save As…” from the Saved Finds pop-up menu. 

3. Type a name for the new definition in the “Find Name” dialog box that appears.

4. Click “OK” to return to the Find window.

Portfolio stores the search definition you just created in the catalog.

The Default Find
Each time you open the Find window (or choose “Default” from the Saved Finds pop-up menu) Portfolio populates the search 
fields and pop-ups with the attributes specified in the Default Saved Find. You can edit the Default Find so that it will retrieve the 
items you use most often. 

To change the Default Find:

1. Open the Find window and set up the search fields as you want them to be by default.

2. Choose “Save as Default” from the Saved Finds pop-up. 

You can change the Default Find as often as you want.

Editing Saved Finds
You can change the search parameters of your Saved Finds, rename them, duplicate, or delete them. You cannot rename or 
delete the Default Find.

To change the attributes of a Saved Find:

1. Choose the Find you want to change from the Saved Finds pop-up menu.

2. Modify the search criteria and choose “Save” from the Saved Finds pop-up menu.

The new search criteria are applied to the Saved Find.

To Rename, Duplicate, or Delete a Saved Find:

1. Choose “Edit List…” from the Saved Finds pop-up menu in the Find window.

The “Saved Finds” dialog box appears.

2. From the list, select the Saved Find that you want to edit. 

3. Click the appropriate button to Rename, Duplicate or Delete the Find.

4. Click “OK” to return to the Find window.

The changes are made to the Saved Find.



Sorting and Reordering Gallery Items

You can sort on any indexed field in the catalog such as File Name, including Custom fields that you have elected to index. You 
use the “View by” options from the View menu to quickly sort items in the active Gallery. 

To Sort the active Gallery:

1. Choose a sort “by” option from the View menu.

— or —

1. Choose “by Other...” from the View menu, or press Command+Option+D (Mac OS) or Ctrl+Shift+D(Windows).

The View by Other dialog box is displayed.

2. From the list, choose the type of sort, and choose “Ascending” or “Descending” order.

3. Click “OK” to sort the list and return to the Gallery window.

To manually Reorder items in the active Gallery:

1. Select the item thumbnail(s) that you wish to relocate, then drag them to the new location.

Note: Changes to the Gallery view, such as adding items to the Gallery, may undo these changes (see sidebar Tip).



Dragging and Dropping Catalog Items into Other Applications
Mac OS: On the Macintosh, you can drag items from Gallery windows into any application that supports drag and drop. Extensis 
provides drag and drop support for QuarkXPress with the “Extensis QX-Drag&Drop” XTension located on the Extensis CD. Run 
the Extensis QX-Drag&Drop Installer to add this XTension to the QuarkXPress XTensions folder.
Windows:On Windows PCs, you can drag and drop items from Gallery windows into any application that supports OLE drag-
and-drop. Check your application’s documentation for information on OLE drag-and-drop support.

To place one or more Catalog items into a Drag and Drop aware application:

1. In the Catalog Gallery window, select the item(s) you wish to place into a drag-and-drop capable document.

2. Drag and drop the item(s) into an open document in the receiving application.

If the receiving application can accept the item’s file type, the item will be placed in the application.

— or —

1. Double-click the item to open the Item Preview window.

2. Mac OS: Use the crosshair cursor to select an area to copy, or choose “Select All” from the Edit menu (Command+A) to 
select the entire image.

Windows: The item is automatically selected.

3. Choose “Copy” from the Edit menu, or press Command+C (Mac OS) or Ctrl+C (Windows).

4. Open a document in the receiving application, then choose “Paste” from the Edit menu, or press Command+V (Mac OS) 
or Ctrl+V (Windows). 

Note: You should not use the “Copy” command (which places items on the clipboard) to place items in other documents, 
unless you do so from the Item Preview window as indicated above. When you use the Copy command from a Gallery 
window, Portfolio expects you to be copying item records between Galleries (within or between Catalogs). 

See Also:
Previewing Catalog Items 



Moving and Copying Items Between Galleries in the Same Catalog
When you move or copy items between Galleries in the same catalog, nothing about the individual item records in the database 
changes—you are merely creating different ways to isolate and view cataloged items. 

To Copy items between Galleries in the same Catalog:

1. Open a Saved Gallery, or create a new Gallery by choosing Window >New Gallery, or click the New Gallery button    on the 
Toolbar, or press        Command+G (Mac OS) or Ctrl+G (Windows).

2. From the originating Gallery, select the item(s) that      you want to copy.

3. Drag and drop the items into the target Gallery window.

— or —

3. Choose “Copy” from the Edit menu [or press Command+C (Mac OS) or Ctrl+C (Windows)].

3a. Activate the receiving Gallery window by clicking it, then choose “Paste” from the Edit menu [Command+V (Mac OS)or 
Ctrl+V (Windows)].

The items will be copied to the new Gallery.

To Move items from one Gallery to another:

1. Open a Saved Gallery, or create a new Gallery by choosing “New Gallery” from the Windows menu, or click the New 
Gallery button    on the Toolbar, or press Command+G (Mac OS) or Ctrl+G (Windows).

2. Choose “Cut” from the Edit menu [Command+X        (Mac OS) or Ctrl+X (Windows)].

3. Activate the receiving Gallery window by clicking it, then choose “Paste” from the Edit menu [Command+V          (Mac OS) 
or Ctrl+V (Windows)].

The items will be removed from the initiating Gallery and added to the receiving Gallery. 

Note: Even if you do not Paste the items into another Gallery, they are not deleted from the Catalog.

See Also:
Moving and Copying Items Between Catalogs 
Deleting Items from a Gallery 
Creating a New Catalog 
Adding Items to a Catalog 



Deleting Items from a Gallery
When items are deleted from a Gallery, they are merely deleted from the current view, not from the catalog. This allows you to 
create Galleries that display just the images you want to see. For example, you can use the Delete from Gallery feature after 
you’ve searched for a set of images and found that it contains a few images that you don’t want to display with the others—
simply delete the ones you don’t want in the Gallery. 

To Delete items from a Gallery:

1. From the Gallery window, select the item(s) that you want to delete.

2. Press the Delete (Mac OS) or Backspace (Windows) key, or choose “Cut” from the Edit menu, or press Command+X (Mac
OS)or Ctrl+X (Windows).

The selected item(s) will be deleted from the Gallery window, but not from the catalog.

— or —

2. Choose “Delete Items” from the Catalog menu.

2a. Choose “Delete from Gallery,” then click “OK.” 

The selected item(s) will be deleted from the Gallery window, but not from the catalog.

See Also:
Deleting Items from a Catalog



Moving and Copying Items Between Catalogs
When you copy items between catalogs, you are actually copying the item record (all of the information associated with the item, 
including the thumbnail, the link to the original file, and any Custom field data—if those Custom fields have been defined in the 
receiving catalog). 
To Copy items between Catalogs:

1. If you have not created Custom fields, proceed to step 2.

If you have created Custom fields in the originating catalog, open the destination catalog and add those Custom fields to it.

If you do not recreate the Custom fields in the destination catalog, Custom field information will be lost when the records 
are copied.

2. In the Gallery window of the originating catalog, select the item(s) that you wish to copy.

3. Drag and drop the items into an open Gallery window in the receiving catalog.

— or —

3. Choose “Copy” from the Edit menu [or press Command+C (Mac OS) or Ctrl+C (Windows)].

3a. Activate the receiving Gallery window by clicking it, then choose Edit >Paste [Command+V (Mac OS) or Ctrl+V 
(Windows)].

The items and all information in the records will be copied to the new Gallery. 
To Move items from one Catalog to another: To move items from one catalog to another you will need to add them to the 
destination catalog and then delete them from the originating catalog. You could do this by making a copy of the catalog and 
deleting the appropriate items from each, or by copying the items to the destination catalog and then deleting them from the 
originating one (using this method you would have to recreate any Custom fields in the destination catalog—see above). Or you 
could create a new catalog and add the desired items to it, then delete the appropriate items from the old catalog (using this 
method you would have to re-enter any information that had been manually added to the record after it had been cataloged).



Deleting Items from a Catalog
Since item records contain so much information that might be difficult to replace if an item is accidentally deleted, Portfolio 
provides some protection from accidentally deleting items from catalogs. First, you must have Publisher or higher level access to
the catalog to delete items. Second, you will be given an opportunity to verify that you really want to delete an item before the 
item is deleted (this notification can be disabled in Edit >Preferences).

To Delete items from a Catalog:

1. From a Gallery window, select the item(s) that you want to delete.

2. Choose “Delete Items” from the Catalog menu.

3. Choose “Delete from Catalog,” then click “OK.”

The selected item(s) will be deleted from the Catalog. 

— or —

2. Press Option+Delete (Mac OS) or Ctrl+Backspace (Windows).

You will be asked to verify the deletion.

3. Click “OK.”

The selected item(s) will be deleted from the Catalog.



Saving Gallery Windows
Once a Gallery window contains the items you want, you can save the window for future use. For example, you may want to 
create a Gallery of items to show to prospective clients. (You    can even present your Gallery as a Slideshow.)
Saved Galleries are static. That is, they are not updated when    you display the Gallery and then modify it in any way—such as 
adding, rearranging, or deleting items. The Gallery must be re-saved in order to preserve changes.

Deleted Items in Saved Galleries
If items in a Saved Gallery window are deleted from the Catalog, the items will still be displayed when the Saved Gallery is 
opened. The thumbnail will be indicated as “Item Deleted.” To eliminate the missing items from the Gallery, choose Refresh from
the View menu [Command+Option+U (Mac OS)or Ctrl+Shift+U (Windows)] then resave the Gallery.

To Save a Gallery:

1. Make sure the Gallery window contains all the items you want and customize as desired.

You can use Find to change the contents of the current Gallery window, or to create a new window, or you can copy or 
drag and drop items from other catalogs, other Galleries, or even add new items. 

2. Sort or manually reorder the Gallery items exactly as you want them to appear.

3. Choose “Save Gallery…” from the Window menu, or press Command+Option+A (Mac OS) or Ctrl+Shift+A (Windows).

The “Save Gallery” dialog box appears.

4. Type a name for the Gallery window and click “OK.”

The Gallery window is saved for later use.

Note: The name you specify for the Gallery does not appear at the top of the Gallery window. Instead, each Gallery for a 
catalog is numbered in the order in which it was created, and that number appears in the window’s title bar with the 
Catalog name.

To Open a saved Gallery:

1. Choose the desired Gallery from the Saved Galleries pop-up menu in the toolbar.

— or —

1. Choose “List Galleries…” from the Window menu [Command+Option+G (Mac OS) or    Ctrl+Shift+G (Windows)].

The “Saved Galleries” dialog box appears.

2. From the list, select the Gallery you want to open,    then click “Open,” or double-click a name on the list.

The Gallery window you selected opens. 

To Edit a Saved Gallery:

1. Choose List Galleries…    from the Window menu, or press Command+Option+G (Mac OS) or    Ctrl+Shift+G (Windows).

The “Saved Galleries” dialog box appears. 

2. Select the Gallery you want to edit.

3. Click “Rename…” to rename the selected Gallery, or click “Delete” to remove the Saved Gallery from the catalog.

4. Click “Done” to close the Saved Galleries dialog box.

Default Galleries
You can set up your catalog so that a specific gallery is displayed when the catalog is initially opened. This is known as the 
Default Gallery.
If you do not specify a Default Gallery of items, each time the catalog is opened it will automatically create a Gallery in Thumbnail
view and display all of the items in the catalog.

To create a Default Gallery:

1. Make sure the Gallery window contains all the items you want and customize as desired.



You can use Find to change the contents of the current Gallery window, or to create a new window, or you can copy or 
drag and drop items from other catalogs, other Galleries, or even add new items.

You can also open a Saved Gallery that you created earlier and make it the Default Gallery.

2. Choose “Save Gallery…” from the Window menu, or press Command+Option+A (Mac OS) Ctrl+Shift+A (Windows).

The “Save Gallery” dialog box appears.

 3. Type “Default” in the Save Gallery dialog box, then    click “OK.”

The saved Gallery becomes the Default Gallery.

See Also:
Slideshows 
Customizing Gallery Views 
Searching the Catalog Using Find Options 



Previewing Catalog Items
When you want to look more closely at any image or play sound or movie items, you can open a Preview window for an item in 
Portfolio. This saves you from having to launch the application that the item’s source file was created in.
The Preview window lets you display and manipulate an item in various ways depending on the item’s type (image, sound or 
movie).

Note: Some file types cannot be previewed. If Portfolio is unable to preview a file type, you are prompted to view the file in the 
application that created it. 

To Preview an item:

• Double-click its thumbnail in the Gallery window.

— or —

• Select the item, then press Command+B (Mac OS) or Ctrl+B (Windows).

— or —

• Select the item, then choose “Preview Original…” from the Item menu.
Before displaying an item in the Preview window, Portfolio must be able to locate the item’s source file—that is, the original file 
from which the catalog entry was made. If the source file cannot be found (because the disk is not mounted or the file has been 
moved or renamed), Portfolio will prompt you to insert the missing disk. If the file is no longer on the requested disk, click 
“Cancel” and Portfolio will allow you to manually locate the missing file.
Portfolio takes advantage of Apple's QuickTime 3.0 capabilities for previewing many multimedia formats, if QuickTime 3.0 is 
installed. QuickTime 3.0 installers for both Mac OS and Windows are available on the Extensis CD.

See Also:
Working with an Item  ’  s Source File  



Viewing Item Properties
You can view all the information available about an individual item from the Item Properties dialog. This view is helpful when you 
want additional information, but don’t want to include it in any of the Gallery views. You can also edit the item’s keywords, 
description, and Custom Fields from the Item Properties dialog.

To view Item Properties:

• Select the item, then choose “Item Properties...” from the Item menu.

— or —

• Select the item, then press Command+I(Mac OS) or Alt+Enter (Windows).
You can have up to ten “Item Properties” dialog boxes open at one time.



Working with an Item’s Source File
Once you have identified a catalog item you want, you can work with it from within the open catalog. For example, you can:

• Switch to another program to edit the source file (the original file to which the catalog entry points).
• Move, Copy, Delete, Find, or Rename the source file.
• Find out more information about the item.
• Print thumbnails or the item itself.

To Edit an item’s source file:

1. Select the item in the Gallery window, or open a Preview window for the item.

2. Choose “Edit Original…” from the Item menu [Command+M (Mac OS) or Ctrl+M (Windows)].

Portfolio remembers the name and location of the application last used to edit the source file for any item of the same type 
and creator. If necessary (such as the first time you attempt to edit a file of a particular type) you will be prompted to 
choose an application and to specify where the application is located.

Portfolio launches the application, and opens the source file for editing.

3. Make the changes you want, save the file, and quit the application.

After quitting the editing application, you are returned to Portfolio.

To Copy a source file:

1. In the Gallery window, select the item(s) whose source file you want to copy.

2. Choose Item > Copy Original… [Command+Option+C (Mac OS) or Ctrl+Shift+C (Windows)].

3. In the file directory dialog box, locate and select the folder you want the original file copied to.

4. Click the “Select” button at the bottom of the directory dialog box.

Portfolio copies the source file into the folder you specified.

Note: You can also copy source files by dragging items from Gallery windows onto the desktop or into folders.

To Move a source file:

1. In the Gallery window, select the item(s) whose source file you want to move.

2. Choose Choose Item > Move Original… [Command+ Option+Y (Mac OS) or Ctrl+Shift+Y (Windows)].

3. In the file directory dialog box, locate and select the folder you want the original file moved to.

4. Click the “Select” button at the bottom of the directory dialog box.

Portfolio moves the source file into the folder you specified.

Note: “Move Original…” moves the source file from its current location to the one you specify. If the source file is locked, 
“Move Original…” does not move the file, but makes a copy of it in the new location.

Portfolio automatically updates the catalog after you move a file.

To Delete a source file:

1. Select the item in the Gallery window.

2. Choose Item >Delete Original… [Command+ Option+X (Mac OS) or Ctrl+Shift+X (Windows)].

3. Click “Cancel” if you change your mind or “OK” to confirm that you want to delete the file.

To Find a source file:

1. In the Gallery window, select the item(s) whose source file you want to find.



2. Choose Choose Item > Find Original… [Command+ Option+F (Mac OS) or Ctrl+Shift+F (Windows)].

The source file will be located and highlighted. Mac OS:    If you select more than one item, Portfolio will open a window for 
each folder containing found items, and highlight all the found source files.

If any of the requested source files cannot be found, Portfolio will locate the files that it can, and present a dialog indicating 
that one or more source files could not be found.

To Rename a source file:

1. Select the item in the Gallery window.

2. Choose Item >Rename Original… [Command+ Option+N (Mac OS) or Ctrl+Shift+N (Windows)].

3. Click “Cancel” if you change your mind or “OK” to confirm that you want to rename the file. 



Viewing Catalog Properties
You can view general information and statistics about any catalog from the Catalog Properties dialog. Statistics include 
Keywords used in the catalog and volumes linked to catalog items. 

To view Catalog Properties:

• Choose Catalog > Catalog Properties... 

— or —

• Press Command+Option+J(Mac OS) or Ctrl+Shift+J (Windows).

The Catalog Properties for the active catalog will be displayed. To view information for another catalog, open it and make it 
the active window. You can have up to ten “Catalog Properties” dialog boxes open at one time.

To view all the Keywords in the Catalog: Open the Catalog Properties dialog (Catalog >Catalog Properties), select the “Statistics 
tab, then click the    to be able to speak with your customer service and have not “Calculate” (Mac OS) or “Calculate Now” 
(Windows) button. Portfolio will list each keyword and indicate how many cataloged items have each keyword assigned. 
Calculating the number of keyworded items may take some time to complete.



Setting Preferences
You can customize Portfolio to suit your working style and work more productively by setting preferences using the 
“Preferences…” command in the Edit menu. 

To set or change User Preferences:

1. Choose “Preferences…” from the Edit menu, or press Command+Option+E (Mac OS) or Ctrl+Shift+E (Windows).

The “User Preferences” dialog box is displayed.

2. Select the desired options.

3. Click “OK.”



Printing Catalog Items
Although you will typically find and select a catalog item either to edit the source file, view it, or use it in another document, you 
might want to print from the catalog itself—to show to a client, for example, or to evaluate items for possible use in a document. 
Choosing “Print…” from the File menu prints the contents of the active window. To print thumbnails or a list of catalog items,    
select the items you want to include and place them into a Gallery window. Select the appropriate Gallery view (Thumbnail, List, 
Record). Customize the Gallery view just the way you want it to appear, including sorting, manually reordering items, background
colors, and the like.
When the Gallery is set up, select “Print.” To print a single full-size image, print from a Preview window.

• If the active window is a Preview window, you see a standard “Print” dialog box that contains no special options for Portfolio.
• If the active window is a Gallery window, the print dialog box includes special Portfolio.

Technical Notes
“Print Using Actual Images” with Quality set to “Best” is a printer-intensive task. Some printers are not equipped with enough 
memory to support the amount of data being downloaded to the printer. If you experience problems, try switching to the “Better” 
or “Good” setting. It’s a good idea to run the “Missing Items” command before printing actual images.
Thumbnails rotated in the catalog are printed with their original orientation when using “Print Using Actual Images.”



Customizing Gallery Views
You can change the layout of any Catalog Gallery view. This allows you to display precisely the information you want to see, 
including the information in any custom fields that you have created.

To customize Gallery views:

1. Choose “Customize…” from the View menu, or press Command+D (Mac OS) or Ctrl+D (Windows), or click the Customize 
button on the Toolbar.

The Customize Gallery dialog will open to the tab associated with the current Gallery view.

2. Select the options you want.

3. If you are going to modify any of the other Gallery views, click “Apply” to apply the selections to the Gallery window without
closing the Customize Gallery dialog box.

4. When you have finished selecting options, click “OK” to apply the changes and close the dialog box.

Note: Click “Save Defaults” to save the current settings as the default layout for each Gallery view. The layout will then be 
used for all new Gallery windows displayed in    each view.

See Also:
Adding Borders to Thumbnails 



Adding Borders to Thumbnails
You can highlight your catalog thumbnails by displaying them in the Gallery window with Thumbnail Borders. Portfolio provides a 
few sample borders for you to use, and you can create unlimited effects using your own border designs.
Any bitmapped image (PICT, BMP) can be used—all you need to do is create your border design, copy it to the system 
clipboard, paste it into the Edit Borders dialog, then select it in the Thumbnail or Record tab of the Customize Gallery dialog. 
All thumbnails in the Gallery window will be displayed with the selected border. Using the Save Galleries feature you can set up 
special Galleries of items with borders, and others without, or specify different borders for different Galleries.
When adding borders, you specify which thumbnail size you want your border to apply to. The Border Box that Portfolio provides 
for each thumbnail size is 25% larger than the thumbnail, so your borders should be 25% larger than the thumbnail size you 
intend to use them with. If your border is larger than the Border Box, it will be scaled down to the proper size. If it is too small it 
will be hidden by the thumbnail; it may be visible if the item displays as an icon.
 

To select a thumbnail border:
1. Choose View > Customize, or press Command+D (Mac OS) or Ctrl+D (Windows), or click the Customize    button.

2. Click the Thumbnails tab or Record tab to select it. 

Borders are not available in List view.

3. Choose the desired thumbnail Border from the Border pop-up menu. 

4. Click “OK” to close the dialog and apply the border to the items in the active Gallery.

To add a thumbnail border to the catalog:

1. From your image editing application, copy your border to the system clipboard. 

2. From Portfolio, choose View > Customize, or press Command+D (Mac OS) or Ctrl+D (Windows), or click the Customize    
button.

3. Click the Thumbnails tab or Record tab to select it. 

Borders are not available in List view.

4. Choose “Edit” from the Border pop-up menu. 

The Edit Borders dialog will be displayed.

5. Click “New,” then enter a name for the border.

6. Select the thumbnail size to which you wish to add the border.

7. Paste the border—it will be pasted into the selected size Border Box. When you have finished in the Edit Borders dialog, 
click “Save.”

You can paste the same or a different border for each thumbnail size.

8. When you have finished in the Customize dialog, click “OK.”

How Borders Work / Border Transparency
Border images are displayed behind the thumbnails. This means that thumbnails and icons will always be displayed in their 
entirety, at whatever size and orientation they are, “overlapping” the border image.
Portfolio looks at the center pixel of the selected border image and sets that as the designated transparency color. This allows 
you to create borders that behave like a transparency mask, allowing the background to show through certain areas of the 
border design. Wherever the transparency color appears in the border image, the background is allowed to show through. So 
you can designate areas of the border image as transparent by coloring them the same color as the center pixels of the border 
image. 
Portfolio always sets a transparency color using the center pixel of the border image, whether you intend to create transparency 
in your border or not. For example: Suppose you have a border image that is a white box with a black border, and your Gallery 
background color is blue. Portfolio will set the transparency color to white because the center pixel of the border image is white. 
If the thumbnails completely cover the white area of the border image, you will not see the blue background. If the thumbnails    
do not completely cover the white area of the border design, some blue will show through. This may or may not be what you 
want. To eliminate potential problems and ensure that you can change backgrounds without being concerned about 
transparency, it’s good practice to add a color in the center of your border image (using a 4 x 4 pixel square works well) that 



does not appear anywhere else in the border image.

To set the transparency color of a Border image:

1. Choose a color that is not used anywhere in the Border design.

This will be your designated transparency color.

2. Color a 4 x 4 pixel area in the center of the image with the transparency color you selected in step 1.

You could color a larger area with the transparency (mask) color, but a 4 x 4 pixel area is large enough to see, yet small 
enough to be completely covered by the item thumbnail or icon.

3. Using the transparency color, color in the areas that you want to mask.

Everywhere on the Border image that the transparency color appears will become transparent, allowing the Gallery 
background to show through.

Note: Thumbnails (and icons) cannot be made transparent. Thumbnails and icons are displayed on top of the Border 
image and will cover the Border design in that area whether the Border is transparent or not.

4. Copy and paste the Border image into the Border Edit dialog.

See Also:
Saving Gallery Windows 



Slideshows
The Portfolio Slideshow feature lets you create slide shows from your catalog images (not thumbnails) that can run automatically
—with the images being advanced in specified intervals—or that can be manually advanced.
Portfolio uses the images in the active Gallery for the slide show.    The screen is blanked and the images are displayed against 
the background color of the current Gallery view. You can elect to show images at their actual image size, or to have them scaled
up to fit as much of the display screen as possible. (If an item is too big for the screen, it is automatically scaled down.) When 
running a Slideshow, if an image is encountered that cannot be found or displayed, the item is skipped.
You can also have the slide show run automatically (Catalog >Administration... > Startup tab) when Portfolio is launched; in this 
case the last-saved Slideshow Options are used. 

To set up a Slideshow:

1. Choose Slideshow Options… from the Catalog menu or press Command+Option+S (Mac OS) or Ctrl+Shift+S (Windows).

2. Select the desired settings, then click “OK.”

To run a Slideshow:

1. Configure a Gallery window with the items you would like to be displayed in the slide show, and arrange the items in the 
order in which you want them to be shown.

You can show still images, 3D images, movies, and sounds. Anything that can be previewed in Portfolio can be displayed 
in the slide show.

2. Choose Slideshow from the Catalog menu, or press Command+S (Mac OS) or Ctrl+S (Windows).

3. For manually run slide shows, click the arrows on the controller to move to the next    or previous    item.

Click the first/last arrows to move to the beginning    or the end    of the show. 

4. Slideshows begin automatically, but you can stop and start the presentation (perhaps to elaborate or answer questions) 
and restart using the pause button    on the mini-controller.    

If the Slideshow is not on “Continuous Loop” it will end when the last item has been displayed.

5. To stop the slideshow and return to the Gallery window, press the Stop    button.

Note: When using a timed delay, images do not start loading until after the delay period. This means that (depending upon 
system parameters) with a delay of 4 seconds, a small image might show up in 4 to 4-1/2 seconds, while a large image 
might take longer.

Hiding the controller: 
You can hide the controller in both automatic and manual mode by clicking it’s Close Box, then use the keyboard commands to 
run the Slideshow.



Technical Notes about Importing and Exporting

1. URL fields are exported and imported with the import and export fields separated by the Group Separator character (just 
like keywords).

2. URL fields are special when importing: If the “Replace Multi-valued” checkbox is Off, existing data in a URL field will not be
changed by imported data; empty URL fields can still receive data. If the checkbox is On, existing URLs will be replaced as
expected with the imported data.

3. Color Mode is exported as a number, not a string, as follows:
Unknown = 0
Black & White = 1
Grayscale = 2
RGB = 3
CMYK = 4
YUV = 5 (TIFF; also known as YCbCr)
Lab = 6
YCCK = 7  (JPEG)

4. Custom Fields of type Date/Time always import/export Time, even if the “Display Time” checkbox is Off. 

5. Custom Fields of type String always import/export carriage returns, even if the “Multi-line Display” checkbox is Off. If multi-
line data is imported and you do not turn this checkbox On, only the first line of data may be visible. 



Importing Field Values
Using Portfolio’s “Import Field Values” you can bring data from an external database into Portfolio by matching fields from the 
database with fields in Portfolio. 
To set up a database file for import into Portfolio, it should be exported as text, with tab delimited fields and carriage return 
delimited records, and should have field headers included (the first record in the text file is assumed to contain the database field
headers and is therefore not imported).
Portfolio should be pre-configured with any required Custom Fields prior to initiating the import. Otherwise, data targeted for 
Portfolio Custom Fields will be not be imported.

To Import Field Values:

1. From the File menu in Portfolio, choose Import >Field Values.

2. Locate the text file to be imported.

3. Match each Import File Field headers from the database (these should be in the first record) with the appropriate Portfolio 
Catalog Field name.

Move the File Fields and Portfolio fields up and down the list to reorder their relative position. Click between the two 
columns to activate the Import pop-up menu. This allows you to select the appropriate import operator: Key, Import, or 
Skip. 

 Symbol          Function         Description  

 = Key Defines the key relationship. The selected Import File Field will be searched for matching values 
in the Portfolio Catalog Field. Only one Key relationship can be designated for the import, and 
only Portfolio Indexed fields can be designated as the Key field.

    --> Import Indicates that the Import File Field will be imported into the Portfolio Catalog Field indicated to the
right of the arrow.

    X Skip Indicates that the Import File Field will not be imported.

4. When you have finished setting up the import fields, you can save the settings for future use. To do so, select “Save As...”   
from the Saved Sets pop-up menu. 

5. When you are ready to import the database, click “Import.”

Portfolio will examine the field value data in Record #2 (the first record with data, since the first record holds the field 
headers) for appropriate data types by comparing each value in the record with the paired Portfolio field type specified at 
the start of the import. If a value does not match, a warning is presented, allowing you to cancel the import.

If all record types match, Portfolio will import the data. As the import progresses, if data in any field of a record does not 
match the paired Portfolio field type, that data is skipped.

Replace Multi-valued Field Data
When checked, values imported into a Multi-valued field overwrite the values in the Portfolio record. When unchecked,    the 
values being imported are added to the end of the list in the Portfolio record.

Technical Notes about Importing Text Files
Because the import text file is delimited by tabs between fields and carriage returns between records, make sure your data does 
not contain either of these characters within a field, as it will cause unexpected results on Importing. Portfolio follows the ASCII 
standard by recognizing ASCII 11 as the Vertical Tab character. This character should be used to denote a linebreak within a field
(such as in a text block like the Description field). Portfolio also recognizes ASCII 29 as the Group Separator character. This 
character should be used to delimit values within a multi-valued field (such as the Keywords field). If you are exporting multi-line 
or multi-valued data from other databases, make sure to use these characters. Some other databases that support multi-valued 
or multi-lined fields (such as FileMaker Pro) also support these standards.

See Also:
Technical Notes about Importing and Exporting 



Export to HTML
The Portfolio Export to HTML function allows you to export catalog items as static Web pages, for posting on a Web Server.
You can specify either that the HTML pages produced will be based on the items and the layout of the currently active Gallery 
view, or you can specify that Portfolio export the pages using a custom HTML settings file (Template). 

To export catalog items as Web pages just as they appear in the active Gallery:

1. Select the desired Gallery view and customize it so that it looks just like you want it to look when viewed on the Web. 
Thumbnails are exported in the order that they displayed in the catalog.

Portfolio creates the Web page layout with the items positioned just as they are in the Gallery, so you may want to reorder 
the items to create just the right display.

2. Select the records that you want to export. 

You must indicate which items in the Gallery you want to export. 

3. Choose File > Export > HTML [Command+Option+H (Mac OS) or Ctrl+Shift+H (Windows)].

The Export HTML dialog will be displayed.

4. In the Export HTML dialog, choose “Use Current View Settings,” then click “Export.”

5. Portfolio will ask you to enter a file name for the first HTML page, and locate where to save the HTML file that are created.

If more than one page of HTML is required (depending on how many records were selected), Portfolio will generate 
additional pages and place them in the same location as the first file. All the Web page files will start with the file name you 
entered, followed by a hyphen (“-”) and a number corresponding the page number. For example, if the first file was named 
“PortWeb.htm”, the second file will be named “PortWeb-1.htm,” etc.

6. Click “Save” to start the export process.

Portfolio will also create a folder named “Images” at the same location as the Web pages. Portfolio will store JPEG 
thumbnails of each of the selected items in the Images folder. If any files (either the HTML files or the thumbnail images) 
already exist in this location, you will be asked whether you want to replace the files or stop the export process.

7. Open the new Web page(s) in your Web browser to preview the results.

Portfolio's HTML Export process generates relative links. This allows you to upload the folder of exported items (all the 
HTML pages and the Images folder) to your Service Provider or to a Web site on your corporate intranet and have the 
items published without hand-coding any HTML and without manually linking the images and pages. Contact your Internet 
Service Provider or System Administrator for assistance in uploading and publishing your folder of catalog Web pages.

Technical Notes about Exporting HTML

1. Portfolio does not export borders in the HTML documents. Any border settings in the Gallery view will be ignored.

2. Portfolio exports thumbnails at the size they were when cataloged, not at the selected display size in the Gallery window. If 
the thumbnails in the catalog were stored at different sizes, the HTML output will display the thumbnails at different sizes. It
is generally recommended that the exported records all use the same size thumbnails. If you do have thumbnails of 
different sizes, use the Modification Method “Update Unconditionally” and enable Regenerate Thumbnails (Cataloging 
Options: Rules tab); this forces the thumbnails to be reset to one size. Be aware that the 256 x 256 thumbnails are roughly 
four times larger than the 112 x 112 thumbnails, so download times over the Internet could be significantly longer if you use
this size, depending on the user's bandwidth.

See Also:
Creating Catalog Web Pages from an HTML Template 
The HTML Template 



Creating Catalog Web Pages from an HTML Template
Besides being able to automatically export HTML based on the current Gallery setup, Portfolio can export your catalog items as 
Web pages using HTML coding that you provide. This gives you great flexibility in creating catalog layouts for the Web. 
The HTML information that you enter can be saved as a template. Any HTML Templates that you create are saved within the 
Portfolio catalog, so you can quickly export any set of records to    Web pages using your pre-defined formats at any time.

To export catalog items as Web pages using an HTML Template:

1. In the active Gallery, select the records that you want to export as Web pages. The records will be exported in the order 
they are displayed in the gallery, so rearrange the records if desired.

2. Select File > Export > HTML (or press Command-Option-H [Ctrl+Shift+H]).

The Export HTML dialog will be displayed. 

3. In the Export HTML dialog, click “Add...” to create a new HTML Export Template.

The Edit HTML    dialog will be displayed, showing the HTML    codes and tags representing the current Gallery view.

4. Enter a name for the template.

5. Choose the number of rows and columns of thumbnails that you want to display on each page. 

This selection controls how many items fit on a page, and as a result, how many pages are generated for each export 
based on the number of items you have selected.

6. Edit the HTML as necessary to produce your desired result. See the following section for details about the three HTML 
data blocks.

7. Click ‘OK’ to save the Template and return to the Export HTML dialog. 

8. In the Export HTML dialog, choose the “Use Template” radio button and select your template in the list.

9. Click “Export” to generate the Web page(s) based on the    information you configured in the template.

See Also:
The HTML Template 



The HTML Template
The three HTML data blocks in the Edit HTML dialog represent the three portions of an HTML document. The Header is the set 
of tags at the top of the file, the Item is the set of tags written once for each record being written into a page, and the Footer is 
the set of tags written at the end of the file.
The following rules apply to each block:

Header:

1. The header must contain the <HTML> tag and the <BODY> tag.

2. Because the grid layout is generated as a table, the Header must end with a <TABLE> tag. 

Footer:

1. The Footer must start by closing out the table with a </TABLE> tag.

2. The Footer should close out with </BODY> and </HTML> tags.

Item:

1. The item block should contain all of the formatting for a particular table cell, including the opening <TD> tag and the closing
</TD> tag.

2. Portfolio will generate the row tags (<TR> and </TR> on its own, based upon the grid dimensions). Do not include these 
tags in any of the cells (unless you are adding your own rows at the top or bottom of the table).

3. The key to properly configuring the Item block is in using macros. Please refer to the following section for information on 
how to use macros.

Macros:
Portfolio uses a macro language in the HTML Templates to allow for substitution of variable data at the time the HTML files are 
actually generated. All macros start and end with a % sign, so the proper use would be %macro%. To display a "%" sign in the 
actual HTML, use two consecutive % signs in the template (i.e. "%%" in the template produces one "%" in the generated output).
The macros are case-insensitive.

Technical Notes on HTML

1. Using the %FIELDNAME%@x makes use of two different form controls (the drop-down menu and the scrolling list box). 
Because of this, the page must contain a <FORM> tag for these tags to be interpreted properly. 

The <FORM> tag can be either in the Item block or in the header. If you plan to have a separate set of form controls on the
page, put the <FORM> tag towards the beginning of the item block (usually just after the <TD> tag) and the </FORM> tag 
towards the end (usually just before the </TD> tag). This will prevent the controls from accidentally causing data to be 
submitted via your Submit control.

2. To display a large text box for a multi-line field, wrap the field in a TEXTAREA tag.

Example: 

<TEXTAREA COLS=50 ROWS = 3 WRAP = "SOFT" NAME = Description>%Description%</TEXTAREA>

Results: This will cause a scrollable box 3 rows by 50 characters to be drawn with the contents of the record’s Description 
field displayed. Note that this is also a FORM control, so the previous note regarding FORM tags applies here as well.

3. As with any HTML code, results will vary based on what make and version of browser the viewer is using. It is 
recommended that you test the generated results with any browsers with which you anticipate your visitors might access 
the pages.

For more information on the specifics of creating pages for the Web and coding in HTML, consult any of the excellent tutorials 
and reference guides available on the Internet, or check your local bookstore or library for additional information.



Export to Text File
You can export your Portfolio catalog data to a text file, and you can specify which fields will be exported and which fields will be 
skipped. Only data for the selected items in the active Gallery will be exported.

To export catalog fields as text:

1. In the Gallery window, select the items for which you want to export text data. 

To select the entire catalog, choose View >Find All [Command+' (Mac OS) or Ctrl+' (Windows) and then Edit>Select All 
[Command+A (Mac OS) or Ctrl+A (Windows)].

2. Choose Export >Text File... [Command+Option+T (Mac OS) or Ctrl+Shift+T (Windows)].

3.    Click in the left-most column of the Catalog Fields list to enable or disable items from export. A checkmark indicates that 
the item will be exported. 

4. Click “Export.”

5. Enter a name for the file and indicate the storage location, then click “OK.”

Portfolio will begin exporting the records and will display a progress bar to keep you posted on its progress. When 
exporting is complete, you will have a tab-delimited text file containing information from each item record that you selected.
In the file, each field within a record is delimited by a tab, and each record is delimited with a carriage return.

Technical Notes about Exporting Text Files
Because the exported text file is delimited by tabs between fields and carriage returns between records, Portfolio cannot use 
either of these characters within a field, as it will result in an improperly formatted file. 
Therefore, Portfolio follows the ASCII standard by using ASCII 11 as the Vertical Tab character. This character will be used to 
denote a linebreak within a field (such as in a text block like the Description field). Portfolio also uses ASCII 29 as the Group 
Separator character. This character will be used to delimit values within a multi-valued field (such as the Keywords field). Some 
other databases that support multi-valued or multi-lined fields (such as FileMaker Pro) also support these standards.

See Also:
Technical Notes about Importing and Exporting 



Export “pnot” Data    (Macintosh only)
The Export “pnot” Data function embeds standard “pnot” resources created in Portfolio, such as keywords and description, 
directly into each selected item’s source file for use in programs like Photoshop.

To update item source files with “pnot” data:

1. Select the items whose source file you want to add “pnot” resources to.

Item’s whose source file cannot be found will be skipped.

2. Choose File > Export > pnot Data...

3.    Select the data you would like to add to the source files. Options are: Thumbnail, Description, and Keywords.

If you select Keywords, you can elect to replace any keywords currently embedded in the item’s source file, or append the 
keywords to the end of any existing list.

4. Click “OK.”

The data fields you selected will be written to the source files of the selected items.

When the export has been completed, Portfolio will display a summary of how many records were successfully updated.
For more information on the Macintosh “pnot” resource search the Apple’s Developer website at: 
http://www.apple.com/developer



Catalog Security / Access Levels

Catalog Access Levels
There are four access levels that can be established for a catalog: Administrator, Publisher, Editor and Reader. Each level can 
have its own password.
Administrator level allows access to all catalog functions, including creating Custom Fields and editing the Master Keyword List. 
Other users can enter data in the Custom Fields, and apply keywords to items from the Master Keywords List. 
The Administrator is responsible for setting all access level passwords, and Administrator is the only access level that can 
change passwords. When a catalog is created it is automatically given Administrator level access, so that you will have access to
all the features functions necessary to set up the catalog.

Important: A shared catalog cannot be accessed by other users when it is in use by the Administrator. Conversely, you cannot 
switch to Administrator level if other users have the catalog open. Multiple users can have Administrator access (if they know 
the password) but only one person at a time can access the catalog when it is in Administrator mode.

Portfolio access levels are inherited; that is, the Administrator level includes the privileges of all other levels (in addition to its 
other privileges), the Publisher level includes the privileges of the Editor and Reader levels, and so on.
You can change catalog access level by selecting “Access” from the Catalog menu.

To change your Access Level to a catalog:

1. Open the catalog.

2. Choose “Access...” from the Catalog menu [or press Command+Option+B (Mac OS) or Ctrl+Shift+B (Windows)].

3. Select the desired access level, then enter the correct password (if a password has been set). 

See Also:
Setting Catalog Passwords 



Setting Catalog Passwords
Multiple users can use a catalog simultaneously across a network, within the restrictions of their access privileges. Therefore, 
password protection is strongly recommended when a catalog is available to multiple users. Protection is not necessary, 
however, if you are the single user of a catalog on your own computer.
You can set passwords when you first create a catalog, or if you have Administrator privileges for the catalog.

To set or change catalog passwords:

1. Open the catalog.

2. Select "Administration..." from the Catalog menu.

The Catalog Administration dialog box is displayed.

3. Click the Passwords tab.

4. Click "Set Password..." for the desired Access Level.

The "Set Password" dialog box is displayed.

 5. Type the new password in the appropriate text box, type it again in the Confirm box, then click “OK.”

Enter the new password in the Confirm field to verify that you entered it correctly. Passwords must be between 4 and 12 
characters in length.

6. Repeat steps 4 and 5 for the other passwords that you want to set.

7. Click "OK" to close the Catalog Administration dialog box and save the new password(s).

8. Close the catalog and reopen it to put the password(s) into effect.

Once a catalog is password-protected with a password for any access level, Passwords access selections are displayed 
when the catalog is opened. Users can then choose their access level from the Access Mode pop-up menu, enter the 
correct password and click “OK” to open the catalog.

Note: Even if you set only a Reader password, users logging in as Editor, Publisher, or Administrator will need that Reader 
password to gain access to the catalog. For example, if you only set an Administrator password, you won’t need to enter a 
password to access the catalog in other access levels.



Creating a Master Keywords List
Establishing a Master Keywords list for a catalog can help you maintain consistent keywords among the items in the catalog, or 
across catalogs. With a Master Keyword list, you can ensure that only the keywords in the list are used in the catalog.
You can enter Master Keywords manually, or you can import them from an existing text file.

Note: Master Keywords are not dynamic. That is, when you change or delete a Master Keyword in the “Catalog 
Administration” dialog box, that Master Keyword is not automatically changed in any items to which it’s been applied.

To add keywords to the Master Keywords list:

1. Choose Catalog > Administration... [Command+H (Mac OS) or Ctrl+H (Windows)].

2. Click the Keywording tab to select it.

3. Type new keywords into the text box at the top of the dialog, then click “Add.”

If you enter a word that is already on the list, the “Add” button will be dimmed.

4. When you have finished adding Master Keywords, click “OK” to save the changes and close the dialog.

To Rename or Delete Master Keywords:

1. Choose Catalog > Administration... [Command+H (Mac OS) or Ctrl+H (Windows)].

2. Click the Keywording tab to select it.

3. Select the keyword that you want to Rename or Delete, then click the appropriate button.

If you selected Rename, enter a new name for the keyword.

4. When you have finished working with Master Keywords, click “OK” to close the dialog and save the changes.

Note:    Deleting a keyword from the Master Keyword list does not remove it from any items that have that keyword 
assigned to them.



Exporting and Importing Keywords
You can export the Master Keywords list from one catalog and import it into another. This is handy if you want to share keywords 
across multiple catalogs. You can also export the standard keywords from any catalog, import it into the Master Keywords list of 
another catalog, then work with the list to rename, add, or remove keywords to build a suitable Master Keywords list.
Portfolio exports keywords to a file in which each keyword is delimited by a carriage return, so you can also import lists of Master
Keywords from any suitable text file.

To Export a list of Master Keywords:

1. Open the catalog that contains the Master Keywords that you want to export. You will need to have Administrator access 
(Catalog >Access).

2. Choose Catalog > Administration... [Command+H (Mac OS) or Ctrl+H (Windows)], then select the Keywording tab.

3. Click “Export...”

4. Specify a name and location for the exported file, then click “Save.”

To Import any list of keywords to the Master Keywords list:

1. Open the catalog that you want to import the keywords into. You will need to have Administrator access (Catalog >Access).

2. Choose Catalog > Administration... [Command+H (Mac OS) or Ctrl+H (Windows)], then select the Keywording tab.

3. Click “Import...”

4. Locate the file containing the keywords that you want to import, then click “Open.”

The keywords will be added to the Master Keywords list.

To Export regular catalog keywords:

1. Open the catalog that contains the keywords that you want to export. (You do not need any special permissions to export 
standard keywords).

2. Choose Catalog > Catalog Properties... [Command+ Option+J (Mac OS) or Ctrl+Shift+J (Windows)]. 

3. Select the Statistics tab.

4. On the Statistics tab, click “Calculate...” (Mac OS) or “Calculate Now” (Windows).

Portfolio will build a list of catalog keywords. If the catalog has many records, this may take some time.

5. Click “Export Keywords...”

6. Specify a name and location for the exported file, then click “Save.”

The keywords will be saved to a file in which each keyword is delimited by a carriage return, so that it can be imported into 
the Master Keywords list of another Portfolio catalog.



Parsing Keyword Phrases
Portfolio offers an option that allows keyword phrases (keywords consisting of more than one word) to be parsed into individual 
keywords. For example, adding the keyword phrase “Mother and child” with keyword phrase parsing on would result in “Mother 
and child,” “Mother,” “and,” and “child” being added to the item.
The advantage of parsing keyword phrases is it allows the user to do a very fast “Starts with” or “Matches” search on words that
would otherwise not be found without using a “contains” search. In the example above, searching on “Starts with child” will only 
return the item if keyword parsing is on.
To enable or disable keyword phrase parsing: Click this option    on the Catalog Administration Keywording tab. The checkmark 
indicates that parsing is enabled.



Adding Custom Fields
Portfolio Catalogs consist of a number of predefined fields. These system fields, such as Filename, Path, Created and so on, 
categorize the file information for each item in a catalog, allowing you to search for specific items based on that information.
In addition to the predefined system fields, you can define Custom Fields to hold specialized information about catalog items. For
instance, you might want to add a field for Web site URLs to a catalog of GIF files, or a “Photographer” field to a catalog of 
photographic images.
There are five Custom Field types from which to choose:

• Date/Time: Enter date and/or time values. You could use this field type to create a Custom Field for image publication dates, for 
example. 

• Decimal: Enter decimal point numeric values. This field type would be useful for custom fields containing stock image prices.

• Integer: Enter regular numeric values. This field type is ideal for custom fields containing catalog part or stock numbers (as long 
as they contain only numeric values).

• String:    Enter text values. This field type can be used for any number of custom fields, including photographer or artist names.

• URL: This field type is used for Web and other URL addresses. It creates an active hyperlink on Windows and on Mac OS 
systems with Internet Config properly set up. You can enter any reference in URL format including: http, ftp, telnet, gopher, even
local files or applications. This field can be used to allow users to click on a web address to go directly to a specific site; or using
a mailto:username@site.com entry, automatically create a mail message addressed to the username@site that you enter.    

You add data to Custom Fields either by typing it into the item record (Item >Item Properties: Fields tab), by extracting data from 
the source file and mapping it to the appropriate Custom Field (Catalog >Cataloging Options: Mappings tab), or by importing 
them (File >Import >Field Values).

Note: When you copy records from one catalog to another, if the catalogs have matching Custom Fields, field data will be 
copied along with other record data. In other words, if you want to copy Custom Field data from one catalog to another, you 
must create identical Custom Fields in each one.

To add Custom Fields to a catalog:
Note: Once a Custom Field has been created and added to the catalog’s Custom Fields list, only the field Name, Display Time
(Date/Time fields only), Multiline Display (String fields only), and Predefined List options can be changed.

1. Choose Catalog > Administration... [Command+H (Mac OS) or Ctrl+H (Windows)].

2. Select the Custom Fields tab.

3. Click “Add..."

The “Custom Field Definition” dialog box appears.

4. Enter a name for the field in the “Name:” text box.

5. Choose the field type from the “Type:” pop-up menu.

The field type determines the values that can be entered into this field. Field types cannot be changed once they are 
defined.

6. Select the appropriate remaining options for the field type you selected, then click “OK” to return to the Custom Fields tab.

7. When you have finished adding Custom Fields, click “OK” to close the Catalog Administration dialog and save changes 
made on any of the tabs.

Custom Field Restrictions

1. Multi-valued String cannot be displayed as multilined.

2. String fields with a predefined list cannot be displayed as multilined.

3. URL fields cannot be set up with a predefined list.

4. URL fields cannot have multiple values.

5. URL fields cannot be indexed.

See Also:
Custom Field Types 





Custom Field Types

ate/Time
This field type allows you to enter date and/or time values into your records. You can elect to have Time values not displayed by 
deselecting the “Display Time”option in the Date/Time Custom Field Definition dialog. Date/Time fields can be indexed, include 
multiple values, and/or be configured as a predefined list.

Note: Times are always assumed when searching on Date/Time fields. That is, if a time value has been entered into the field 
(either by extraction from the source file when the item was cataloged, or by entering a time in the field) and then hidden by 
turning off “Display Time,” the time will still be noted by Portfolio when a search is generated. For example: Searching for 
“5/20/98” will not find a record which contains “5/20/98 3:00 pm” because the request is interpreted as “5/20/98 12:00:00.” 
This is true even if the time is not being displayed.

Decimal
This field type allows you to enter decimal point numeric values with a precision up to 8 decimal points. Decimal fields can be 
Indexed, include multiple values, and/or be configured as a predefined list. To set the Precision, select it from the pop-up.

Integer
This field type allows you to enter regular numeric values. Integer fields can be Indexed, include multiple values, and/or be 
configured as a predefined list.

String
This field type allows you to enter text values. You can specify a maximum string length for the field by entering the number of 
allowable characters in the Length text box. String fields can be indexed, include multiple values, and/or be configured as a 
predefined list. You can elect to have String fields displayed on multiple lines up to by enabling the “Multiline Display” option. 
This option is disallowed if the String field has been set up with multiple values or as a predefined list.

URL
This field type allows you to enter Web and other URL addresses. If the syntax is correct for a URL, the data will become an 
active hyperlink on Windows, and on Mac OS systems with Internet Config properly set up. To create an active link, enter any 
reference in URL format including: http, ftp, telnet, gopher, even local files or applications. Typically URL data might look like: 
http://www.extensis.com; ftp://ftp.extensis.com/pub/file1.zip; http://www.extensis.com/buynow/cgi?sku=012345; 
mailto:username@extensis.com. 
When you edit a URL to add data to it (Item > Item Properties) the Title that you enter is displayed in the record and becomes the
active link (Portfolio links the Title to the actual URL in the URL field). You can give the URL any Title you like—the Title does not 
need to refer to the actual URL. 

Note: When importing data into a URL field (Import >Field Values), Portfolio treats the URL field as a multi-valued field with 
two values. The first value is the Title and the second value is the URL address. If you wish to import URLs into Portfolio they 
must conform to this format. Portfolio follows the same formatting when exporting URL data. 

Predefined Lists
You can create Predefined Lists of items for your Custom Fields. By predefining field entry data you can provide master lists of 
data that users can select from when entering data in Custom Fields. All of the Custom Field types except URL can be set up 
with a predefined list.
Like the Master Keywords list, this ensures that the exact same data is entered in the data field every time. For example, you 
might want to create a list of your standard vendors and enter the appropriate vendor name to an item’s record by selecting it 
from the list. Deleting an item from a predefined list does not delete it from items that have that data assigned.

Multiple Value Lists
Multi-value lists allow you to specify Custom Fields that can contain more than one value. Keywords is an example, but you 
might want to define other multi-value lists, such as multiple vendor names or multiple item pricing. 
To set up a Custom Field with Multiple Values: Open the Custom Fields Definition dialog (Catalog >Administration: Custom 
Fields tab and click “Add”). Choose any field type except URL, then click “Multiple Values.”
As with all Custom Fields, you add data to the list of values by typing it into the item record (Item >Item Properties: Fields tab), 
by extracting data from the source file and mapping it to the appropriate Custom Field (Catalog >Cataloging Options: Mappings 
tab), or by importing it (File >Import >Field Values.)
You can specify how many lines are made available to display the multiple value data in Record view (View >Customize: Record 
tab). In the Record tab Fields List, fields that have (or can have) multiple lines of data display a number in the right-most column. 
To change the number of display lines, select a number from the Display Fields pop-up (Macintosh) or enter a number in the Edit
String dialog (Windows). If no additional lines have been selected, this number defaults to 1.

Multiline Display
Enabling Multiline Display gives you a multiple-line scrolling text box when you edit the field (Item >Item Properties: Fields tab). 
This allows you to add as much information in the box as you have allowed for in the Length field. The Multiline Display option 
applies only to String fields, and only to String fields that do not have multiple values and do not use a predefined list.
To create a Multiline display Custom Field: Open the Custom Fields Definition dialog (Catalog >Administration: Custom Fields 
tab, click “Add”). Choose field type “String” and click the “Multiline Display” checkbox. 



You can specify how many lines are made available to display the multiline data in Record view (View >Customize: Record tab). 
In the Record tab Fields List, fields that have (or can have) multiple lines of data display a number in the right-most column.    To 
change the number of display lines, select a number from the Display Fields pop-up (Macintosh) or enter a number in the Edit 
String dialog (Windows). If no additional lines have been selected, this number defaults to 1.

Indexing Custom Fields
You can elect to have any number of Custom Fields indexed so that searching these fields is faster. You can also sort on single-
value fields that are indexed. 



Setting Catalog Startup Options
The Startup Options allow you to determine which, if any, processes will be run automatically when the catalog is opened. 
Options are: 

• Open Find Dialog

• Open MKL (Master Keywords List)    Palette

• Run Slideshow

• Display Custom Splashscreen

Note: Large splashscreens add to catalog size and can take a long time to load. It’s good practice to size your 
splashscreen so that it is no larger than the screen.



Maintaining a Catalog
Catalogs—especially large ones—that are heavily used and frequently updated can become out-of-date. In addition to routinely 
backing up all catalogs and source files (and keeping the backups in a safe place), it is a good idea to perform other 
housecleaning tasks regularly as well. Portfolio provides the catalog manager or administrator with tools that can help with 
routine catalog maintenance.

Removing Items from a Catalog
The “Delete Items...” command lets you clear a catalog of unwanted or out-of-date items or references.

To remove specific items from a catalog:

1. In the catalog Gallery window, select the items that you want to delete.

2. Select “Delete Items...” from the Catalog menu.

The “Delete Items” dialog box is displayed.

3. Select “Delete from Catalog” (Mac OS) or “Delete from Catalog and Gallery”(Windows),    then click “OK.”

Note: Select “Delete from Gallery” if you want to remove the item from the Gallery window only; the item remains in the 
catalog when you click “OK.”

— or —

1. In the Gallery window select the items that you delete and press Option+Delete (Mac OS) or Ctrl+Backspace (Windows).

Checking for Missing Files
You can easily determine if any file references in a Portfolio catalog are no longer valid using the “Missing Files...” command 
[Choose Catalog >Missing Items, or press Command+Option+M (Mac OS) or Ctrl+Shift+M (Windows)]. Portfolio only checks for 
missing files on mounted volumes. 

Recovering Damaged Catalogs
Should you ever have trouble opening a Portfolio catalog and suspect that it may have been damaged, you may be able to 
recover it using the Recover command. Another time to run the Recovery command run is when you experience crashes when 
sorting or searching on a particular field.

To Recover a catalog:

1. Close the catalog that you want to recover. 

You cannot run the Recovery command on an open catalog.

2. Choose “Recover...” from the File menu, or press Command+Option+V (Mac OS) or Ctrl+Shift+V (Windows).

A directory dialog box is displayed.

3. Locate the catalog you want to recover, then click “Open.”

A second directory dialog box is displayed.

4. Type a new name for the recovered catalog, select where you want to save it, then click “Save.”

A progress window is displayed as Portfolio checks the catalog and attempts to repair the damage. 

5. When the completed status report is displayed, click “OK.”
Open the recovered catalog to verify that all the items are intact.

See Also:
Deleting Items from the Catalog 
Identifying Missing Files 
 



Using Portfolio on a Network
A single Portfolio catalog can contain references to source files on multiple hard disks, network servers, CD-ROM discs, or 
removable disks, whether these media are mounted or not. When Portfolio needs to retrieve a source file that resides on a 
network volume, it automatically mounts that volume, prompting for a volume password when required.
If a source file is stored on removable media, such as floppy disks or CD-ROMs, Portfolio prompts for the disk by name. Portfolio
also prompts for source files that have been moved or renamed.

Shared Catalogs
Portfolio provides two ways to share catalogs in a multi-user, networked environment:
Filesharing: Filesharing uses standard system networking to share catalogs on either a dedicated file server somewhere or on a 
user’s computer (provided that filesharing is turned on). Users connect to these catalogs by choosing Open, navigating to the 
particular volume, and selecting the catalog itself. Each user’s Portfolio application (client) intelligently sets flags within the 
catalog file itself to control things such as when other users are allowed to access the catalog, and when other users should be 
blocked from writing to a particular record. For example, when one user writes to a record, other users accessing the catalog are 
blocked from writing to that record. Filesharing does not require the addition of Portfolio Server software, but fewer users can 
access catalogs simultaneously. Catalog operations like searching are much slower than with Portfolio Server software installed.
Client/Server: In this networking scheme, special Portfolio Server software is used to manage catalogs on an NT server 
machine. The Portfolio Server application opens the catalogs,    and monitors the network for clients. End-users, running 
standard Portfolio application software (client), access the Server using the    “Connect to Server” command. Once connected to 
the server users can select catalogs to open. The server software then controls all catalog access. Portfolio Server software 
allows a larger number of simultaneous users, and most catalog operations are performed significantly faster. Note: The number 
of users permitted to connect simultaneously is set by the multi-user license agreement. Additional connection requests will be 
refused by the Portfolio Server when this limit is reached.

Network Security Protection
Your organization is authorized to use as many copies of Portfolio as designated in your site license agreement. When you run 
Portfolio on a network, the application checks the network to see how many copies of Portfolio with the same serial number are 
running. If the program finds that more duplicate serial numbers are in use than are in the site license agreement, an alert box 
appears. Click “OK” to close the alert box. Another user must quit Portfolio before you can launch the copy that you want to use.
If you did not purchase a Portfolio site license, only one copy of Portfolio per serial number may be in use on your network.

Filesharing Network Concerns
In a typical network scenario, many users would open Portfolio, locate items they want, and leave Portfolio running in the 
background while they switch to other applications to edit source files, work on other documents, read e-mail, and so forth. 
Meanwhile, at any given time, only some of those users would be actively using the catalog to search for and preview items they 
might be interested in, while fewer still might be adding or updating items, keywords, or descriptions.
The greater the number of users who have a catalog open, the slower individual searches will be, depending on what tasks the 
users are performing in Portfolio. The speed of the network and computer can also affect the performance of Portfolio.
If you are experiencing performance problems in a multi-user network environment, your situation may benefit from installing a 
Portfolio Server to manage catalog access.



Managing Source Files
There are many ways to organize the source files for items in a Portfolio catalog. Each strategy has advantages and 
disadvantages, but considering the options and planning ahead can save you time in the long run and significantly increase 
Portfolio’s usefulness to you and your workgroup.
One of the key benefits of using Portfolio is that you do not need to remember where a source file is located or what it is called. 
However, because Portfolio can use filenames, folder names, or entire pathnames as keywords, and because you can then use 
those keywords to help in searching, a rational plan for naming and organizing files and folders is helpful.
Each workgroup must ultimately decide what works best for its own situation based on how the group works and how work flows 
through it. Here are a few suggestions that might help in your planning.

Organizing Source Files
One of the most obvious ways to organize files into folders is to set up a series of folders for each project, client, or category (for 
example, travel, business or architecture). Within a folder, use subfolders to partition related files appropriately.
Another approach is to organize files into folders by file type, by parent application, or by department of origin (for example, 
Marketing, Sales or Publications).
Once you’ve organized your files into folders, it’s easy to include the files into Portfolio catalogs.

Naming Source Files
Use naming and organizing strategies together to make the most of keyword searching in Portfolio. Once you have decided how 
to organize your files, consider the following alternatives for naming them:

• Use file extensions to indicate file type. This is very important when using Portfolio in a cross-platform environment, where you’ll
want to keep Windows file naming restrictions in mind when naming Macintosh files and vice versa.

• Use number or alphabetic prefixes to help sort items in ways that matter for the kinds of files you use. For example, you might 
use frame numbers for images from a single photo shoot or counter or time code readings for sounds, movies, or images 
digitized from video or audio tape.



Overview
Welcome to Extensis™ Portfolio™! Portfolio is an easy-to-use and efficient cataloging tool that allows you to organize all your 
creative work into on-line libraries that can be browsed. Whether your creative content is created on Macintosh or Windows, 
shared over a network, or accessed from remote locations using TCP/IP, Portfolio will forever change the way you view, 
organize, manage, select, share and use digital content. 
Portfolio allows you to build visual catalogs from digital media including images, sounds, movies, and documents automatically, 
with detailed reference information and thumbnail images. You can catalog any media regardless of application, then effortlessly 
retrieve them by visually searching or by searching using keywords or other criteria. You can view your media files as 
thumbnails, as a list, or as individual records, and customize the views to suit your needs.
Portfolio also lets you stay in sync with other users by sharing your catalogs over networks and across platforms. You can import 
databases of information into your catalog, and even    export catalogs or specified items as Web pages.

See Also:
What is Portfolio? 
What  ’  s New in Portfolio 4.0?   
Portfolio Basics 



System and Software Requirements
To install and use Portfolio, you will need the following:

Macintosh:

•    Apple® Power Macintosh® or PowerPC compatibles
•    Mac OS® System 7.5.3 or later    (System 7.5.5 or higher recommended)
•    6M application RAM, minimum
•    20M free hard disk space
•    Open Transport 1.1 or higher (Only if you will be connecting to catalogs being served by Portfolio Server software)

Note: If you commonly work with large files or large catalogs, you may need to increase the amount of RAM allocated to 
Portfolio.

Windows:
•    486/33MHz or faster PC    (Pentium 133MHz or faster recommended)
•    Microsoft® Windows 95®, Windows 98® or Windows NT® 4.0 
•    6M application RAM, minimum
•    20M free hard disk space
•    TCP/IP Services (Only if you will be connecting to catalogs being served by Portfolio Server software)



Registration
It is important to register your copy of Portfolio so we can provide you with the best possible service. Registered users of 
Portfolio are eligible for technical support, information regarding new versions and products, discounts and special offers on new 
products. 
Your registration number is located on the back cover of this manual. You will need to enter that number to personalize your copy
of Portfolio. If you choose not to personalize your copy, Portfolio will run in a demonstration mode that allows you to use the 
product for 30 days. You can purchase additional registration numbers in the US at 1-800-796-9798 or 1-503-274-2020. In 
Europe call 31 (0) 30 247 50 50.



Technical Support
For questions regarding Portfolio, please first refer to this manual, which describes the features and basic operations. We invite 
you to visit our Portfolio page on the Extensis website (www.extensis.com) for frequently asked questions and trouble-shooting 
tips.
If you have a question which is not addressed in this manual or on the Extensis website, Technical Support is available by phone
at (503) 274-7030, Monday through Friday, 8:00 a.m. to 5:00 p.m. Pacific time. When calling for technical support, please be at 
your computer and have the following information available: your Portfolio registration number, your computer configuration, and 
your question or a description of the difficulty you’re experiencing—what specifically occurs and when. Take note of any 
displayed error numbers or messages and any other information you think may be relevant.



What is Portfolio?
Portfolio is a digital image cataloging application. Using Portfolio you can take images—including graphics, presentations, 
movies, sounds and other digital media files, even documents—that you or members of your workgroup create and put them into
common catalogs. You can then view, edit, copy, and retrieve items from the catalog and transfer them to other documents, 
regardless of file format, location, platform, or applications that created the files.
It’s quick and easy to view and retrieve images in Portfolio catalogs because the catalog stores only thumbnail images of the file 
(along with whatever additional information you require), rather than the full document or image. Portfolio creates pointers to the 
original files, so the originals are always available for copying to applications, previewing, editing, etc., while allowing the catalog 
itself to be fast and efficient. 
There is no limit to the number of items a single catalog can contain (bearing in mind that the more items in a catalog, the more 
memory and time are required for common operations). To each item in a catalog, you can add:
• An unlimited number of keywords that will help you easily search for and select catalog items.
• A description (up to 32,000 characters long) that lets you store important or useful information about the file.
• Unlimited custom fields, including special field types such as Date/Time, Strings with multiple values and predefined lists, 

URLs, and more.

In a workgroup setting, you can allow all users full access to all catalog functions, or you can designate catalog administrators to 
create, maintain, and control access to catalogs for the entire workgroup. With Portfolio installed on their computers, members of
your workgroup can simultaneously search, view, and use items from catalogs whose source files are located on one or many 
network servers, shared volumes, CD-ROMs or removable drives. Users can access the Portfolio Server remotely using TCP/IP, 
and you can even create Web pages of cataloged items.



What’s New in Portfolio 4.0?
Portfolio version 4.0 is a major upgrade to this popular cataloging program, adding a number of exciting new features and 
enhancements. Minor enhancements are too numerous to mention, but the major new features and enhancements are listed 
below.

New to Portfolio in version 4.0 are:
• Record View—A vertically scrolling list of records that allows you to focus on individual catalog items by allowing the full text 

of all fields to be displayed along with the thumbnail.
• Slideshow—Allows you to display catalogs as self-running or manually controlled slide shows for review and/or presentation.
• URL fields—Allows you to build hyperlinks inside Portfolio records, so you can go to a location on the Internet right from the 

record.
• Export to HTML—Gives you the ability to export catalog items as Web pages, complete with JPEG thumbnails.
• Search and Replace—Allows you to change field values using powerful search and replace technology.
• Borders—Gives you the ability to add borders to thumbnail representations in Thumbnail and Record view.
• Scripting—Gives you the ability (using AppleScript on the Macintosh or Visual Basic on Windows) to automate tasks inside 

Portfolio or between Portfolio and other applications, including using Watch folders for automated cataloging. 
• Importing—Adds the ability to map database data to Portfolio fields, including custom fields.
• Client/Server Option—Offers a dedicated Portfolio Server for improved performance, and to allow more users to connect 

simultaneously. Clients access Portfolio served catalogs using the standard Portfolio application. Note: Portfolio Server is a 
separate product.

Enhancements include:
• Translators—Supports additional formats and improved importing. Adds the ability to view information about source files, 

such as the size and resolution of an image. 
• Splash Screen—Lets you specify a custom splash screen to be presented when the catalog is opened.
• Cataloging Options—Reorganized and more powerful, making catalog options easier to understand and use.



Portfolio Basics
When you create a new Portfolio catalog or add items to an existing catalog, Portfolio gathers information about the item and 
creates a record for it in the Portfolio database. If the source file being cataloged includes a thumbnail and/or icon, the thumbnail 
and/or icon can be added to the item’s record.
Portfolio does not import the item itself, but creates a link to the file that contains the cataloged item. This allows you to view, 
search, and retrieve cataloged items quickly, and to view and search for items even when the original file is not available (such 
as on a hard disk, CD, or network volume that is not mounted). The only time you need to access the original file is when you 
want to Preview the image, Edit the image, or copy it to another application.
If a cataloged item is moved to another location, renamed, or if other information about the original file changes, you will want to 
make Portfolio aware of the change by “updating” the record.
You view cataloged items in a window called the “Gallery.” Portfolio provides several different Gallery views, and each of these 
views can be customized to meet your needs. You can add additional information to item records such as keywords, description, 
and Custom Fields, and then search for cataloged items using keywords, or use Portfolio’s powerful Find function to locate items
using any of the information fields assigned to them.
If your catalogs are being used in a workgroup and/or network environment, you can use Portfolio’s Access Level options to limit 
access to the different cataloging functions. 



Converting a Portfolio 3.0 Catalog
To access the rich new features added to Portfolio 4.0, catalogs created in Portfolio 3.0 must be converted to version 4 catalogs. 
Portfolio 4.0 can open Portfolio 3.0 catalogs without conversion, in a limited browsing mode.
Opening a version 3.0 catalog with Portfolio version 4.0 in Administrator mode allows the catalog to be converted.

To convert a Portfolio 3.0 Catalog:
1. Set the default access mode (Edit >Preferences) to “Administrator.”

This will automatically open the catalog in Administrator mode. If the catalog requires a password for Administrator level 
access, you will be prompted to provide it. If you open the catalog in any other mode, the catalog will automatically be 
opened in a limited browsing mode.

Windows only: If you have just one catalog to convert, you can select Administrator mode from the Open 
dialog. This opens the current catalog in Administrator mode without changing the default access mode setting. 

2. Open the catalog to be updated. 

You will be asked to confirm the conversion. 

3. Click “OK.”

The catalog is converted and all options (Catalog options, saved Galleries, etc., are preserved.) 

Choose “Cancel” to open the catalog in limited browsing mode, leaving it set as a version 3.0 catalog.

To open a Portfolio 3.0 Catalog without converting it:
• Open the catalog in any mode except Administrator mode.

You will be informed that the catalog will be opened in a limited browsing mode. 

— or —

• Open the catalog in Administrator mode and click “Cancel” when asked to confirm the conversion.

The catalog will be automatically be opened in a limited browsing mode. 

When the catalog is closed it will still be a Portfolio version 3.0 catalog.



Converting a Fetch 1.2/1.5 Catalog    (Macintosh)
Due to the rich new features added to Portfolio 4.0, earlier catalogs, such as those created in Fetch, cannot be opened directly. 
To convert the catalog Portfolio will create a new version 4.0 catalog containing the records from the Fetch catalog.    

To convert a Fetch 1.2 or Fetch 1.5 Catalog:
1. Open Portfolio 4.0. 

2. Open the catalog to be converted. 

You will be asked to confirm the conversion. 

3. Click “OK.”

4. Enter a name and location for the new catalog.

The records will be converted and added to the new catalog. The original Fetch catalog is left untouched.

If errors occurred during the conversion process, a log file will be generated. This log file will be given the same name as 
the catalog with the extension “.log” added. The log file is a text file that lists the record number of each record which could
not be converted. You can use this list to scroll the catalog (from the Fetch application) to view the records that did not 
convert.

You can skip records that are causing errors by pressing the Option key after specifying the name of the new catalog. This 
displays a dialog allowing you to indicate a record number from which to start the conversion. Choosing a record number 
beyond the set of problem records causes Portfolio to skip the troublesome records and start cataloging with the indicated 
records. 



Converting Cumulus Catalogs    (Macintosh)
To import an existing Cumulus catalog you will need to export the catalog database in Cumulus, then import those records into 
Portfolio.

To convert a Cumulus Catalog:

In Cumulus:

1. Select the records you want to convert to Portfolio, or choose “Select All” from the Edit menu to select the entire catalog.

2. Choose File > Export Record...

3. Specify a file name and location where you want to save the Export file.

In Portfolio:

4. Either open an existing Portfolio 4.0 catalog, or create a new Portfolio catalog. 

The import process can import records into either a new or existing catalog.

5. Select Publisher access level or higher (Catalog >Access > Publisher).

6. Choose File > Import > Cumulus Database...

7. From the Open file dialog, locate and select the Export file you saved in step 3, then click “Open.” 

8. Portfolio will display a progress bar while it converts the records into its own format. Note that the original source files do 
not have to be available during the conversion process.

Fields from the Cumulus database are imported as indicated in the table on the following page.

Cumulus Portfolio
Record name > Filename

Notes > Description
Categories > Keywords

File Size > File Size
File > Path

Program > Creator Mac
Type > File Type Mac

Vertical Resolution > Vertical Resolution
Horizontal Resolution > Horizontal Resolution

Height > Height
Width > Width

Created > Created
Modified > Last Modified

Cataloged > Cataloged
Modified (2) > Last Updated

File > Volume

Cumulus Fields not Imported into Portfolio: 
• Color Mode (Cumulus’ color modes do not match the color modes used by Portfolio)

• Status

• User Name
Additional Notes:

1. The Portfolio field Zone Mac is populated if the path points to a different AppleTalk zone.

2. The Portfolio field Extension Win is generated based on the filename (the same way Portfolio generates it when 
cataloging).

3. The thumbnail is imported at whatever size it was saved in Cumulus.

4. The Portfolio fields “Thumbnail Size” and “Color Mode”      are left blank. To populate this information, the Portfolio records 
need to be updated with the Regenerate Thumbnail option enabled. This will also reset the thumbnail to a standard 
Portfolio size, which could result in space savings in the catalog. 

See Also:



Updating Cataloged Items 




